ramips: add support for Xiaomi Mi Wi-Fi Router 3G v2
[openwrt/openwrt.git] / target / linux / brcm2708 / Makefile
index 8dc923907d23f7d694c54ee395ed66d4811b5602..d93575891ee90771598d4a5d372d045cd8f6f7d7 100644 (file)
@@ -1,5 +1,6 @@
 #
-# Copyright (C) 2012-2016 OpenWrt.org
+# Copyright (C) 2012-2019 OpenWrt.org
+# Copyright (C) 2017 LEDE project
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -9,11 +10,11 @@ include $(TOPDIR)/rules.mk
 ARCH:=arm
 BOARD:=brcm2708
 BOARDNAME:=Broadcom BCM27xx
-FEATURES:=ext4 audio usb usbgadget display gpio fpu
+FEATURES:=ext4 audio usb usbgadget display gpio fpu squashfs rootfs-part boot-part
 MAINTAINER:=Álvaro Fernández Rojas <noltari@gmail.com>
-SUBTARGETS:=bcm2708 bcm2709 bcm2710
+SUBTARGETS:=bcm2708 bcm2709 bcm2710 bcm2711
 
-KERNEL_PATCHVER:=4.9
+KERNEL_PATCHVER:=4.19
 
 define Target/Description
        Build firmware image for Broadcom BCM27xx SoC devices.
@@ -21,7 +22,12 @@ define Target/Description
 endef
 
 include $(INCLUDE_DIR)/target.mk
-DEFAULT_PACKAGES += brcm2708-gpu-fw kmod-usb-hid kmod-sound-core kmod-sound-arm-bcm2835 kmod-fs-vfat kmod-nls-cp437 kmod-nls-iso8859-1
+DEFAULT_PACKAGES += \
+       brcm2708-gpu-fw \
+       kmod-usb-hid \
+       kmod-sound-core kmod-sound-arm-bcm2835 \
+       kmod-fs-vfat kmod-nls-cp437 kmod-nls-iso8859-1 \
+       partx-utils mkf2fs e2fsprogs
 
 KERNELNAME:=Image dtbs