brcm2708: Add Raspberry Pi 4 support
[openwrt/openwrt.git] / target / linux / brcm2708 / image / Makefile
index c3e7cbac4858adbccff064e0374c24a74681a9ce..c850acdc257e5041b3f43038cf9e443ac1c0a244 100644 (file)
@@ -21,18 +21,12 @@ define Build/kernel-img
        mv $@.tmp $@
 endef
 
-define Build/boot-img
+define Build/boot-common
        rm -f $@.boot
        mkfs.fat -C $@.boot $(FAT32_BLOCKS)
        mcopy -i $@.boot $(KDIR)/COPYING.linux ::
        mcopy -i $@.boot $(KDIR)/bootcode.bin ::
        mcopy -i $@.boot $(KDIR)/LICENCE.broadcom ::
-       mcopy -i $@.boot $(KDIR)/start.elf ::
-       mcopy -i $@.boot $(KDIR)/start_cd.elf ::
-       mcopy -i $@.boot $(KDIR)/start_x.elf ::
-       mcopy -i $@.boot $(KDIR)/fixup.dat ::
-       mcopy -i $@.boot $(KDIR)/fixup_cd.dat ::
-       mcopy -i $@.boot $(KDIR)/fixup_x.dat ::
        mcopy -i $@.boot cmdline.txt ::
        mcopy -i $@.boot config.txt ::
        mcopy -i $@.boot $(IMAGE_KERNEL) ::$(KERNEL_IMG)
@@ -42,6 +36,24 @@ define Build/boot-img
        mcopy -i $@.boot $(DTS_DIR)/overlays/README ::/overlays/
 endef
 
+define Build/boot-2708
+       mcopy -i $@.boot $(KDIR)/start.elf ::
+       mcopy -i $@.boot $(KDIR)/start_cd.elf ::
+       mcopy -i $@.boot $(KDIR)/start_x.elf ::
+       mcopy -i $@.boot $(KDIR)/fixup.dat ::
+       mcopy -i $@.boot $(KDIR)/fixup_cd.dat ::
+       mcopy -i $@.boot $(KDIR)/fixup_x.dat ::
+endef
+
+ define Build/boot-2711
+       mcopy -i $@.boot $(KDIR)/start4.elf ::
+       mcopy -i $@.boot $(KDIR)/start4cd.elf ::
+       mcopy -i $@.boot $(KDIR)/start4x.elf ::
+       mcopy -i $@.boot $(KDIR)/fixup4.dat ::
+       mcopy -i $@.boot $(KDIR)/fixup4cd.dat ::
+       mcopy -i $@.boot $(KDIR)/fixup4x.dat ::
+endef
+
 define Build/sdcard-img
        ./gen_rpi_sdcard_img.sh $@ $@.boot $(IMAGE_ROOTFS) \
                $(CONFIG_TARGET_KERNEL_PARTSIZE) $(CONFIG_TARGET_ROOTFS_PARTSIZE)
@@ -52,8 +64,8 @@ define Device/Default
   KERNEL := kernel-bin | kernel-img
   KERNEL_IMG := kernel.img
   IMAGES := factory.img.gz sysupgrade.img.gz
-  IMAGE/sysupgrade.img.gz := boot-img | sdcard-img | gzip | append-metadata
-  IMAGE/factory.img.gz := boot-img | sdcard-img | gzip
+  IMAGE/sysupgrade.img.gz := boot-common | boot-2708 | sdcard-img | gzip | append-metadata
+  IMAGE/factory.img.gz := boot-common | boot-2708 | sdcard-img | gzip
 endef
 
 define Device/rpi
@@ -74,8 +86,8 @@ ifeq ($(SUBTARGET),bcm2708)
 endif
 
 define Device/rpi-2
-  DEVICE_TITLE := Raspberry Pi 2B/3B/3B+/3CM
-  DEVICE_DTS := bcm2709-rpi-2-b bcm2710-rpi-3-b bcm2710-rpi-3-b-plus bcm2710-rpi-cm3
+  DEVICE_TITLE := Raspberry Pi 2B/3B/3B+/3CM/4B
+  DEVICE_DTS := bcm2709-rpi-2-b bcm2710-rpi-3-b bcm2710-rpi-3-b-plus bcm2711-rpi-4-b bcm2710-rpi-cm3
   SUPPORTED_DEVICES := \
        rpi-2-b rpi-3-b rpi-3-b-plus rpi-cm \
        raspberrypi,2-model-b \
@@ -85,8 +97,10 @@ define Device/rpi-2
        brcmfmac-firmware-43430-sdio \
        brcmfmac-firmware-43430-sdio-rpi-3b \
        brcmfmac-firmware-43455-sdio brcmfmac-firmware-43455-clm_blob \
-       brcmfmac-firmware-43455-sdio-rpi-3b-plus \
+       brcmfmac-firmware-43455-sdio-rpi-3b-plus brcmfmac-firmware-43455-sdio-rpi-4b \
        kmod-brcmfmac wpad-basic
+  IMAGE/sysupgrade.img.gz := boot-common | boot-2708 | boot-2711 | sdcard-img | gzip | append-metadata
+  IMAGE/factory.img.gz := boot-common | boot-2708 | boot-2711 | sdcard-img | gzip
 endef
 ifeq ($(SUBTARGET),bcm2709)
   TARGET_DEVICES += rpi-2