kernel: update kernel to 3.10.15
[openwrt/openwrt.git] / target / linux / brcm47xx / Makefile
index 11485fe056e84f9532a73b7a317a31e1c33ce024..f95562274e795ce6e91ef8ffc459aaea3ae22f74 100644 (file)
@@ -1,5 +1,5 @@
-# 
-# Copyright (C) 2006 OpenWrt.org
+#
+# Copyright (C) 2006-2008 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -9,19 +9,17 @@ include $(TOPDIR)/rules.mk
 ARCH:=mipsel
 BOARD:=brcm47xx
 BOARDNAME:=Broadcom BCM947xx/953xx
-FEATURES:=squashfs usb
+FEATURES:=squashfs usb pcmcia
+MAINTAINER:=Hauke Mehrtens <hauke@hauke-m.de>
+
+LINUX_VERSION:=3.10.15
 
-LINUX_VERSION:=2.6.22.4
+include $(INCLUDE_DIR)/target.mk
+DEFAULT_PACKAGES += swconfig kmod-diag wpad-mini nvram
 
 define Target/Description
        Build firmware images for Broadcom based routers
        (e.g. Netgear WGT634U)
 endef
 
-include $(INCLUDE_DIR)/kernel-build.mk
-DEFAULT_PACKAGES += kmod-switch kmod-diag
-
-# include the profiles
--include profiles/*.mk
-
-$(eval $(call BuildKernel))
+$(eval $(call BuildTarget))