brcm47xx: image: use new (& fixed) FILESYSTEM variable for trx command
[openwrt/openwrt.git] / target / linux / brcm47xx / image / Makefile
index 09405c910c87ea9a6e01ab9e64439d13ec2b190a..6a691436df1a13241ce5a7ba1b507038a41eb140 100644 (file)
@@ -113,7 +113,7 @@ define Build/trx-with-loader
                -o $@ \
                -f $(KDIR)/loader.gz \
                -f $(word 1,$^) \
-               $(call trxalign/$(lastword $(subst ., ,$(word 2,$^))),$(lastword $(subst ., ,$(word 2,$^))))
+               $(call trxalign/$(FILESYSTEM),$(FILESYSTEM))
 endef
 
 define Build/linksys-bin