bump to 3.3.8
[openwrt/openwrt.git] / target / linux / brcm63xx / Makefile
index eecfd9bcff5f923be7280030c6bcd1b2acb9f608..098820f40582c5fb202954de53a9160dc9cb79fa 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2006-2008 OpenWrt.org
+# Copyright (C) 2006-2009 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -9,17 +9,19 @@ include $(TOPDIR)/rules.mk
 ARCH:=mips
 BOARD:=brcm63xx
 BOARDNAME:=Broadcom BCM63xx
-FEATURES:=squashfs jffs2 usb atm
-LINUX_VERSION:=2.6.27.10
+FEATURES:=squashfs jffs2 usb atm pci pcmcia
+LINUX_VERSION:=3.3.8
+MAINTAINER:=Florian Fainelli <florian@openwrt.org>
 
 include $(INCLUDE_DIR)/target.mk
 
-DEFAULT_PACKAGES += hostapd-mini
+DEFAULT_PACKAGES += kmod-switch kmod-input-gpio-keys-polled \
+       kmod-button-hotplug
 
 define Target/Description
        Build firmware images for Broadcom based xDSL/routers
-       currently supports BCM6348 and BCM6358 based devices.
-       (e.g. Inventel Livebox, Siemens SE515)
+       currently supports BCM6338, BCM6348 and BCM6358 based devices.
+       (e.g. Inventel Livebox, Siemens SE515, Neufbox 4)
 endef
 
 $(eval $(call BuildTarget))