brcm63xx: switch to linux 4.4
[openwrt/openwrt.git] / target / linux / brcm63xx / Makefile
index c1a1a59802cd53eb7f6e859e43db872b86c57ff9..0dba065d0d4c3b0f1faf1344c67e3521283db25e 100644 (file)
@@ -1,5 +1,6 @@
 #
-# Copyright (C) 2006-2008 OpenWrt.org
+# Copyright (C) 2006-2009 OpenWrt.org
+# Copyright (C) 2016 LEDE project
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -9,16 +10,18 @@ include $(TOPDIR)/rules.mk
 ARCH:=mips
 BOARD:=brcm63xx
 BOARDNAME:=Broadcom BCM63xx
-FEATURES:=squashfs jffs2 usb atm pci
-LINUX_VERSION:=2.6.27.19
+SUBTARGETS:=generic smp
+FEATURES:=squashfs usb atm pci pcmcia usbgadget
+KERNEL_PATCHVER:=4.4
+MAINTAINER:=Jonas Gorski <jogo@openwrt.org>
 
 include $(INCLUDE_DIR)/target.mk
 
-DEFAULT_PACKAGES += hostapd-mini
+DEFAULT_PACKAGES += swconfig kmod-gpio-button-hotplug
 
 define Target/Description
        Build firmware images for Broadcom based xDSL/routers
-       currently supports BCM6348 and BCM6358 based devices.
+       currently supports BCM6338, BCM6348 and BCM6358 based devices.
        (e.g. Inventel Livebox, Siemens SE515, Neufbox 4)
 endef