kernel: update kernel to 3.10.15
[openwrt/openwrt.git] / target / linux / brcm63xx / Makefile
index ba4dc0c9e61f7e605e7db7411ffb1a5cc4898b73..1fb2edf29749f2fb54f9eff3c652fa45ece8c9fa 100644 (file)
@@ -1,5 +1,5 @@
-# 
-# Copyright (C) 2006 OpenWrt.org
+#
+# Copyright (C) 2006-2009 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -9,15 +9,19 @@ include $(TOPDIR)/rules.mk
 ARCH:=mips
 BOARD:=brcm63xx
 BOARDNAME:=Broadcom BCM63xx
-FEATURES:=squashfs jffs2 usb atm
-LINUX_VERSION:=2.6.27.9
+SUBTARGETS:=generic smp
+FEATURES:=squashfs usb atm pci pcmcia
+LINUX_VERSION:=3.10.15
+MAINTAINER:=Florian Fainelli <florian@openwrt.org>
 
 include $(INCLUDE_DIR)/target.mk
 
+DEFAULT_PACKAGES += swconfig kmod-input-gpio-keys-polled kmod-button-hotplug
+
 define Target/Description
        Build firmware images for Broadcom based xDSL/routers
-       currently supports BCM6348 and BCM6358 based devices.
-       (e.g. Inventel Livebox, Siemens SE515)
+       currently supports BCM6338, BCM6348 and BCM6358 based devices.
+       (e.g. Inventel Livebox, Siemens SE515, Neufbox 4)
 endef
 
 $(eval $(call BuildTarget))