bcm63xx: pad Speedport W303 V images to 4 MiB
[openwrt/openwrt.git] / target / linux / brcm63xx / image / Makefile
index f82647e98372beef412b27e9c4559b36e0ecb32e..303003c79372cf5ca2f114372aabd68f28a63613 100644 (file)
@@ -93,7 +93,7 @@ define Image/Build/SPW303V
                --output $(BIN_DIR)/openwrt-$(4)-$(1)-cfe.bin.tmp \
                --boardid $(2) --chipid $(3) --entry $(KERNEL_ENTRY) \
                --load-addr $(LOADADDR) --rsa-signature "$(5)" \
-               $(6) $(7) $(8) $(9)
+               --pad 4 $(6) $(7) $(8) $(9)
        # Fix up header
        $(STAGING_DIR_HOST)/bin/spw303v -i $(BIN_DIR)/openwrt-$(4)-$(1)-cfe.bin.tmp \
                -o $(BIN_DIR)/openwrt-$(4)-$(1)-cfe-sysupgrade.bin