brcm63xx: remove broken DSP platform device code
[openwrt/openwrt.git] / target / linux / brcm63xx / patches-4.9 / 356-MIPS-BCM63XX-move-fallback-sprom-support-into-its-ow.patch
index cec6c7e1a7c88157065453174a6c889ca06353de..859aa739bd9646dcf5a982d7a3051388a67cecd3 100644 (file)
@@ -20,18 +20,19 @@ Signed-off-by: Jonas Gorski <jogo@openwrt.org>
 
 --- a/arch/mips/bcm63xx/Makefile
 +++ b/arch/mips/bcm63xx/Makefile
 
 --- a/arch/mips/bcm63xx/Makefile
 +++ b/arch/mips/bcm63xx/Makefile
-@@ -2,7 +2,7 @@ obj-y          += clk.o cpu.o cs.o gpio.o irq.o
-                  setup.o timer.o dev-dsp.o dev-enet.o dev-flash.o \
-                  dev-pcmcia.o dev-rng.o dev-spi.o dev-hsspi.o dev-uart.o \
-                  dev-wdt.o dev-usb-ehci.o dev-usb-ohci.o dev-usb-usbd.o \
--                 usb-common.o
-+                 usb-common.o sprom.o
+@@ -1,7 +1,8 @@
+ obj-y         += clk.o cpu.o cs.o gpio.o irq.o nvram.o prom.o reset.o \
+                  setup.o timer.o dev-enet.o dev-flash.o dev-pcmcia.o \
+                  dev-rng.o dev-spi.o dev-hsspi.o dev-uart.o dev-wdt.o \
+-                 dev-usb-ehci.o dev-usb-ohci.o dev-usb-usbd.o usb-common.o
++                 dev-usb-ehci.o dev-usb-ohci.o dev-usb-usbd.o usb-common.o \
++                 sprom.o
  obj-$(CONFIG_EARLY_PRINTK)    += early_printk.o
  
  obj-y         += boards/
 --- a/arch/mips/bcm63xx/boards/board_common.c
 +++ b/arch/mips/bcm63xx/boards/board_common.c
  obj-$(CONFIG_EARLY_PRINTK)    += early_printk.o
  
  obj-y         += boards/
 --- a/arch/mips/bcm63xx/boards/board_common.c
 +++ b/arch/mips/bcm63xx/boards/board_common.c
-@@ -40,44 +40,6 @@
+@@ -39,44 +39,6 @@
  static struct board_info board;
  
  /*
  static struct board_info board;
  
  /*
@@ -76,7 +77,7 @@ Signed-off-by: Jonas Gorski <jogo@openwrt.org>
   * return board name for /proc/cpuinfo
   */
  const char *board_get_name(void)
   * return board name for /proc/cpuinfo
   */
  const char *board_get_name(void)
-@@ -180,6 +142,7 @@ static struct platform_device bcm63xx_gp
+@@ -179,6 +141,7 @@ static struct platform_device bcm63xx_gp
  int __init board_register_devices(void)
  {
        int usbh_ports = 0;
  int __init board_register_devices(void)
  {
        int usbh_ports = 0;
@@ -84,7 +85,7 @@ Signed-off-by: Jonas Gorski <jogo@openwrt.org>
  
        if (board.has_uart0)
                bcm63xx_uart_register(0);
  
        if (board.has_uart0)
                bcm63xx_uart_register(0);
-@@ -224,15 +187,10 @@ int __init board_register_devices(void)
+@@ -220,15 +183,10 @@ int __init board_register_devices(void)
        /* Generate MAC address for WLAN and register our SPROM,
         * do this after registering enet devices
         */
        /* Generate MAC address for WLAN and register our SPROM,
         * do this after registering enet devices
         */