build: unify arm target cflags
[openwrt/openwrt.git] / target / linux / cns21xx / Makefile
index 5970906be8ca1eeb3a8d2d24fe2c59c737c35791..30066abdb139eb840c32d2aaa53698d643987fca 100644 (file)
@@ -10,9 +10,9 @@ ARCH:=arm
 BOARD:=cns21xx
 BOARDNAME:=Cavium Networks Econa CNS21xx
 FEATURES:=squashfs
-CFLAGS:=-Os -pipe -march=armv4 -mtune=fa526 -fno-caller-saves
+CPU_TYPE:=fa526
 
-LINUX_VERSION:=3.8.13
+LINUX_VERSION:=3.10.12
 
 include $(INCLUDE_DIR)/target.mk
 
@@ -24,4 +24,6 @@ define Target/Description
  Build firmware images for Cavium Networks CNS21XX based boards.
 endef
 
+KERNELNAME:="zImage uImage"
+
 $(eval $(call BuildTarget))