cns3xxx: advertise pcie usb usbgadget features
[openwrt/openwrt.git] / target / linux / cns3xxx / Makefile
index 86ca83a54ec7665087d10bbf376821270ba7977c..50c0e948f29e890185048214ea21f821da4b8810 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2010 OpenWrt.org
+# Copyright (C) 2010-2012 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -9,11 +9,11 @@ include $(TOPDIR)/rules.mk
 ARCH:=arm
 BOARD:=cns3xxx
 BOARDNAME:=Cavium Networks Econa CNS3xxx
-FEATURES:=squashfs fpu gpio
+FEATURES:=squashfs fpu gpio pcie usb usbgadget
 CFLAGS:=-Os -pipe -march=armv6k -mtune=mpcore -mfloat-abi=softfp -mfpu=vfp -fno-caller-saves
 MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
 
-LINUX_VERSION:=2.6.39
+LINUX_VERSION:=3.3.8
 
 include $(INCLUDE_DIR)/target.mk
 
@@ -24,4 +24,6 @@ endef
 
 KERNELNAME:="uImage"
 
+DEFAULT_PACKAGES += kmod-ath9k kmod-usb2 wpad-mini
+
 $(eval $(call BuildTarget))