cns3xxx: switch to linux 4.9
[openwrt/openwrt.git] / target / linux / cns3xxx / Makefile
index e2297a64784b4314ab3a8f1da50217cb1737c34b..817bb317ef977e7fd61df2fce73d13d923cc681b 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2010 OpenWrt.org
+# Copyright (C) 2010-2012 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -9,19 +9,22 @@ include $(TOPDIR)/rules.mk
 ARCH:=arm
 BOARD:=cns3xxx
 BOARDNAME:=Cavium Networks Econa CNS3xxx
-FEATURES:=squashfs fpu gpio
-CFLAGS:=-Os -pipe -march=armv6k -mtune=mpcore -mfloat-abi=softfp -mfpu=vfp -fno-caller-saves
-MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
+FEATURES:=squashfs fpu gpio pcie usb usbgadget
+CPU_TYPE:=mpcore
+CPU_SUBTYPE:=vfp
+MAINTAINER:=Felix Fietkau <nbd@nbd.name>
 
-LINUX_VERSION:=2.6.39.4
-
-include $(INCLUDE_DIR)/target.mk
+KERNEL_PATCHVER:=4.9
 
 define Target/Description
        Build images for Cavium Networks Econa CNS3xxx based boards,
        eg. the Gateworks Laguna family
 endef
 
-KERNELNAME:="uImage"
+include $(INCLUDE_DIR)/target.mk
+
+KERNELNAME:=zImage
+
+DEFAULT_PACKAGES += kmod-ath9k kmod-usb2 wpad-mini
 
 $(eval $(call BuildTarget))