cns3xxx: don't use invalid mask value for clock events
[openwrt/openwrt.git] / target / linux / cns3xxx / Makefile
index 7105c45ea1bec23ffc182a85c206a214fee14d5e..abb1fccf322c8f8e455bbe191c38e5a14f0cffd4 100644 (file)
@@ -12,19 +12,19 @@ BOARDNAME:=Cavium Networks Econa CNS3xxx
 FEATURES:=squashfs fpu gpio pcie usb usbgadget
 CPU_TYPE:=mpcore
 CPU_SUBTYPE:=vfp
-MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
-
-LINUX_VERSION:=3.8.13
-
-include $(INCLUDE_DIR)/target.mk
+MAINTAINER:=Felix Fietkau <nbd@nbd.name>, \
+           Koen Vandeputte <koen.vandeputte@ncentric.com>
+KERNEL_PATCHVER:=4.14
 
 define Target/Description
        Build images for Cavium Networks Econa CNS3xxx based boards,
        eg. the Gateworks Laguna family
 endef
 
-KERNELNAME:="zImage"
+include $(INCLUDE_DIR)/target.mk
+
+KERNELNAME:=zImage
 
-DEFAULT_PACKAGES += kmod-ath9k kmod-usb2 wpad-mini
+DEFAULT_PACKAGES += kmod-ath9k kmod-usb2 wpad-basic
 
 $(eval $(call BuildTarget))