global cflags: remove -funit-at-a-time, it is ignored by recent compilers. instead...
[openwrt/openwrt.git] / target / linux / cobalt / Makefile
index 266e4dfdbf36c02b682783cc76ca71a06bdaeed5..81c9839be0945431e6993aeeceb8f400d4dbe433 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2009 OpenWrt.org
+# Copyright (C) 2009-2011 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -9,10 +9,10 @@ include $(TOPDIR)/rules.mk
 ARCH:=mipsel
 BOARD:=cobalt
 BOARDNAME:=Cobalt Microservers
-FEATURES:=tgz pci ext2
-CFLAGS:=-O2 -pipe -mtune=r5000 -funit-at-a-time
+FEATURES:=targz pci ext4
+CFLAGS:=-O2 -pipe -mtune=r5000 -fno-caller-saves
 
-LINUX_VERSION:=2.6.30.10
+LINUX_VERSION:=2.6.32.33
 
 include $(INCLUDE_DIR)/target.mk