define a shared IMG_PREFIX variable used as a basename for image files, it contains...
[openwrt/openwrt.git] / target / linux / coldfire / image / Makefile
index 0228a8dcf65f7c06667f676710b4d31527194fb4..94e28b2cbb6c1aeedbac39710dc81efcdec0a808 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2009 OpenWrt.org
+# Copyright (C) 2009-2010 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -17,7 +17,7 @@ define Image/BuildKernel
                -R .note.gnu.build-id -S $(LINUX_DIR)/vmlinux $(KDIR)/vmlinux.bin
        mkimage -A m68k -O linux -T kernel -a 0x00020000 -e 0x00020000 \
                -C none -n 'M68K OpenWrt Linux-$(LINUX_VERSION)' \
-               -d $(KDIR)/vmlinux.bin $(BIN_DIR)/openwrt-$(BOARD)-uImage
+               -d $(KDIR)/vmlinux.bin $(BIN_DIR)/$(IMG_PREFIX)-uImage
 endef
 
 define Image/Build