dump to 2.6.30-rc5, override device_type
[openwrt/openwrt.git] / target / linux / etrax / Makefile
index 119dbb29d70dcced785ca9cffa2a206d3f3decc4..4d021ff7c00773b130463582399c20f2610d6efc 100644 (file)
@@ -1,5 +1,5 @@
-# 
-# Copyright (C) 2006 OpenWrt.org
+#
+# Copyright (C) 2006-2009 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -9,19 +9,16 @@ include $(TOPDIR)/rules.mk
 ARCH:=cris
 BOARD:=etrax
 BOARDNAME:=Foxboard (ETRAX 100LX)
-FEATURES:=squashfs jffs2 broken
-LINUX_VERSION:=2.6.25.1
+FEATURES:=squashfs jffs2
+LINUX_VERSION:=2.6.30-rc5
+DEVICE_TYPE=
 
 include $(INCLUDE_DIR)/target.mk
 
 KERNELNAME:="zImage"
-DEFAULT_PACKAGES += foxboard-utils
 
 define Target/Description
-       Build fimware images for the FOXBOARD made by acmesystems.it
+       Build firmware images for the FOXBOARD made by acmesystems.it
 endef
 
 $(eval $(call BuildTarget))
-$(eval $(call RequireCommand,/usr/local/cris/gcc-cris, \
-       Please install the binary cris toolchain. \
-))