gemini: create zImage for DIR-685
[openwrt/openwrt.git] / target / linux / gemini / image / Makefile
index 1c51b62f68636b40ab03b1e2f86b7b46afa07b01..3e122fc457ae8915df1ba8e9be7200cea1062d30 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2009-2014 OpenWrt.org
+# Copyright (C) 2009-2018 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 include $(TOPDIR)/rules.mk
 include $(INCLUDE_DIR)/image.mk
 
-ifeq ($(SUBTARGET),wiligear)
-define Image/Prepare
-# WBD111: mach id 1690 (0x69a)
-       echo -en "\x06\x1c\xa0\xe3\x9a\x10\x81\xe3" > $(KDIR)/$(IMG_PREFIX)-wbd111-zImage
-       cat $(KDIR)/zImage >> $(KDIR)/$(IMG_PREFIX)-wbd111-zImage
-# WBD222: mach id 2753 (0xAC1)
-       echo -en "\x0a\x1c\xa0\xe3\xc1\x10\x81\xe3" > $(KDIR)/$(IMG_PREFIX)-wbd222-zImage
-       cat $(KDIR)/zImage >> $(KDIR)/$(IMG_PREFIX)-wbd222-zImage
+# Just copy the zImage for D-Link DIR-685
+define Build/dir685-images
+       cp $(IMAGE_KERNEL) $(BIN_DIR)/$(IMG_PREFIX)-dir685-zImage
 endef
-endif
 
-ifeq ($(SUBTARGET),raidsonic)
-define Image/Prepare
-# NAS4220: mach id 2038 (0x7F6)
-       echo -en "\x07\x1c\xa0\xe3\xf6\x10\x81\xe3" > $(KDIR)/$(IMG_PREFIX)-nas4220-zImage
-       cat $(KDIR)/zImage >> $(KDIR)/$(IMG_PREFIX)-nas4220-zImage
+# Build D-Link DNS-313 images using the special header tool.
+# rootfs.tgz and rd.tgz contains nothing, we only need them
+# to satisfy the boot loader on the device. The zImage is
+# the only real content.
+define Build/dns313-images
+       if [ -d $(BIN_DIR)/.boot ] ; then rm -rf $(BIN_DIR)/.boot ; fi
+       mkdir -p $(BIN_DIR)/.boot
+       echo "dummy" > $(BIN_DIR)/.boot/dummyfile
+       dns313-header $(BIN_DIR)/.boot/dummyfile \
+               $(BIN_DIR)/.boot/rootfs.tgz
+       dns313-header $(BIN_DIR)/.boot/dummyfile \
+               $(BIN_DIR)/.boot/rd.gz
+       dns313-header $(IMAGE_KERNEL) \
+               $(BIN_DIR)/.boot/zImage
+       rm -f $(BIN_DIR)/.boot/dummyfile
+       (cd $(BIN_DIR); tar -czf $(IMG_PREFIX)-dns313-bootpart.tar.gz .boot)
+       if [ -d $(BIN_DIR)/.boot ] ; then rm -rf $(BIN_DIR)/.boot ; fi
 endef
-endif
 
-ifeq ($(SUBTARGET),wiligear)
-define Image/BuildKernel
-# workaround the bootloader's bug with extra nops
-       echo -en "\x00\x00\xa0\xe1\x00\x00\xa0\xe1\x00\x00\xa0\xe1\x00\x00\xa0\xe1" > $(BIN_DIR)/$(IMG_PREFIX)-wbd111-zImage
-       cat $(KDIR)/$(IMG_PREFIX)-wbd111-zImage >> $(BIN_DIR)/$(IMG_PREFIX)-wbd111-zImage
-       echo -en "\x00\x00\xa0\xe1\x00\x00\xa0\xe1\x00\x00\xa0\xe1\x00\x00\xa0\xe1" > $(BIN_DIR)/$(IMG_PREFIX)-wbd222-zImage
-       cat $(KDIR)/$(IMG_PREFIX)-wbd222-zImage >> $(BIN_DIR)/$(IMG_PREFIX)-wbd222-zImage
+# Create the special NAS4220B image format with the squashfs
+# split across two "partitions" named rd.gz and hddapp.tgz but
+# essentially just being used by OpenWRT as one big partition
+define Build/nas4220b-images
+       dd if=$(IMAGE_ROOTFS) of=$(BIN_DIR)/rd.gz bs=6144k conv=sync
+       dd if=$(IMAGE_ROOTFS) of=$(BIN_DIR)/hddapp.tgz bs=6144k count=1 seek=1
+       cp $(IMAGE_KERNEL) $(BIN_DIR)/zImage
+       cp ./ImageInfo-ib4220 $(BIN_DIR)/ImageInfo
+       (cd $(BIN_DIR); tar -czf $(IMG_PREFIX)-sysupgrade-ib4220b.tar.gz ImageInfo zImage rd.gz hddapp.tgz)
+       mv $(BIN_DIR)/rd.gz $(BIN_DIR)/$(IMG_PREFIX)-nas4220b-rd.gz
+       mv $(BIN_DIR)/hddapp.tgz $(BIN_DIR)/$(IMG_PREFIX)-nas4220b-hddapp.tgz
+       mv $(BIN_DIR)/zImage $(BIN_DIR)/$(IMG_PREFIX)-nas4220b-zImage
+       rm -f $(BIN_DIR)/ImageInfo
 endef
-endif
 
-define Image/Build/jffs2-64k
-       dd if=$(KDIR)/root.$(1) of=$(BIN_DIR)/$(IMG_PREFIX)-$(1).img bs=64k conv=sync
+# WBD-111 and WBD-222:
+# work around the bootloader's bug with extra nops
+# FIXME: is this really needed now that we no longer append the code
+# to change the machine ID number? Needs testing on Wiliboard.
+define Build/wbd-nops
+       mv $@ $@.tmp
+       echo -en "\x00\x00\xa0\xe1\x00\x00\xa0\xe1\x00\x00\xa0\xe1\x00\x00\xa0\xe1" > $@
+       cat $@.tmp >> $@
+       rm -f $@.tmp
 endef
 
-define Image/Build/jffs2-128k
-       dd if=$(KDIR)/root.$(1) of=$(BIN_DIR)/$(IMG_PREFIX)-$(1).img bs=128k conv=sync
+# All DTB files are prefixed with "gemini-"
+define Device/Default
+       DEVICE_DTS := $(patsubst %.dtb,%,$(notdir $(wildcard $(if $(IB),$(KDIR),$(DTS_DIR))/*-$(1).dtb)))
+       KERNEL_DEPENDS = $$(wildcard $(DTS_DIR)/$$(DEVICE_DTS).dts)
+       KERNEL_NAME := zImage
+       KERNEL := kernel-bin | append-dtb
+       FILESYSTEMS := squashfs
+       IMAGE_NAME := $$(IMAGE_PREFIX)-$$(1).$$(2)
+       BLOCKSIZE := 128k
+       PAGESIZE := 2048
 endef
 
-define Image/Build/squashfs
-       $(call prepare_generic_squashfs,$(KDIR)/root.squashfs)
-       dd if=$(KDIR)/root.$(1) of=$(BIN_DIR)/$(IMG_PREFIX)-$(1).img bs=128k conv=sync
+# A reasonable set of default packages handling the NAS type
+# of devices out of the box (former NAS42x0 IcyBox defaults)
+GEMINI_NAS_PACKAGES:=kmod-md-mod kmod-md-linear kmod-md-multipath \
+               kmod-md-raid0 kmod-md-raid1 kmod-md-raid10 kmod-md-raid456 \
+               kmod-fs-btrfs kmod-fs-cifs kmod-fs-nfs \
+               kmod-fs-nfsd kmod-fs-ntfs kmod-fs-reiserfs kmod-fs-vfat \
+               kmod-nls-utf8 kmod-usb-storage-extras \
+               samba36-server mdadm cfdisk fdisk e2fsprogs badblocks
+
+define Device/dlink-dir-685
+       DEVICE_TITLE := D-Link DIR-685 Xtreme N Storage Router
+       DEVICE_PACKAGES := $(GEMINI_NAS_PACKAGES) \
+                       kmod-switch-rtl8366rb swconfig
+       IMAGES += dir685-image
+       IMAGE/dir685-image := dir685-images
 endef
+TARGET_DEVICES += dlink-dir-685
 
-ifeq ($(SUBTARGET),wiligear)
-define Image/Build
-       $(call Image/Build/$(1),$(1))
-       -$(STAGING_DIR_HOST)/bin/mkfwimage2 \
-               -m GEOS -f 0x30000000 -z \
-               -v WILI-S.WILIBOARD.v5.00.SL3512.OpenWrt.00000.000000.000000 \
-               -o $(BIN_DIR)/$(IMG_PREFIX)-wbd111-$(1).bin \
-               -p Kernel:0x020000:0x100000:0:0:$(BIN_DIR)/$(IMG_PREFIX)-wbd111-zImage \
-               -p Ramdisk:0x120000:0x500000:0:0:$(BIN_DIR)/$(IMG_PREFIX)-$(1).img
+define Device/dlink-dns-313
+       DEVICE_TITLE := D-Link DNS-313 1-Bay Network Storage Enclosure
+       DEVICE_PACKAGES := $(GEMINI_NAS_PACKAGES)
+       IMAGES += dns313-image
+       IMAGE/dns313-image := dns313-images
+endef
+TARGET_DEVICES += dlink-dns-313
 
-       -$(STAGING_DIR_HOST)/bin/mkfwimage2 \
-               -m GEOS -f 0x30000000 -z \
-               -v WILI-S.WBD222.v5.00.SL3512.OpenWrt.00000.000000.000000 \
-               -o $(BIN_DIR)/$(IMG_PREFIX)-wbd222-$(1).bin \
-               -p Kernel:0x020000:0x100000:0:0:$(BIN_DIR)/$(IMG_PREFIX)-wbd222-zImage \
-               -p Ramdisk:0x120000:0x500000:0:0:$(BIN_DIR)/$(IMG_PREFIX)-$(1).img
+define Device/nas4220b
+       DEVICE_TITLE := Raidsonic NAS IB-4220-B
+       IMAGES += nas4220b-image
+       IMAGE/nas4220b-image := nas4220b-images
+       DEVICE_PACKAGES := $(GEMINI_NAS_PACKAGES)
 endef
-endif
+TARGET_DEVICES += nas4220b
 
-ifeq ($(SUBTARGET),raidsonic)
-define Image/Build
-       $(call Image/Build/$(1),$(1))
-       dd if=$(BIN_DIR)/$(IMG_PREFIX)-$(1).img of=$(BIN_DIR)/rd.gz bs=6144k count=1
-#      dd if=/dev/zero of=$(BIN_DIR)/hddapp.tgz bs=6144k count=1
-       dd if=$(BIN_DIR)/$(IMG_PREFIX)-$(1).img of=$(BIN_DIR)/hddapp.tgz bs=6144k count=1 seek=1
-       cp $(KDIR)/$(IMG_PREFIX)-nas4220-zImage $(BIN_DIR)/
-       cp $(BIN_DIR)/$(IMG_PREFIX)-nas4220-zImage $(BIN_DIR)/zImage
-       cp ./ImageInfo-ib4220 $(BIN_DIR)/ImageInfo
-       (cd $(BIN_DIR); tar -czf $(IMG_PREFIX)-sysupgrade-ib4220.tar.gz ImageInfo zImage rd.gz hddapp.tgz)
-       mv $(BIN_DIR)/rd.gz $(BIN_DIR)/$(IMG_PREFIX)-nas4220-rd.gz
-       mv $(BIN_DIR)/hddapp.tgz $(BIN_DIR)/$(IMG_PREFIX)-nas4220-hddapp.tgz
-       rm -f $(BIN_DIR)/zImage $(BIN_DIR)/ImageInfo
+define Device/rut1xx
+       DEVICE_TITLE := Teltonika RUT1xx
+       DEVICE_PACKAGES := $(GEMINI_NAS_PACKAGES)
+endef
+TARGET_DEVICES += rut1xx
+
+define Device/sq201
+       DEVICE_TITLE := ITian Square One SQ201
+       DEVICE_PACKAGES := $(GEMINI_NAS_PACKAGES) rt61-pci-firmware
+endef
+TARGET_DEVICES += sq201
+
+define Device/wbd111
+       DEVICE_TITLE := Wiliboard WBD-111
+       KERNEL := kernel-bin | append-dtb | wbd-nops
+endef
+TARGET_DEVICES += wbd111
+
+define Device/wbd222
+       DEVICE_TITLE := Wiliboard WBD-222
+       KERNEL := kernel-bin | append-dtb | wbd-nops
 endef
-endif
+TARGET_DEVICES += wbd222
 
 $(eval $(call BuildImage))