gemini: dlink-dir-685: fix rt2800-pci package name
[openwrt/openwrt.git] / target / linux / gemini / image / Makefile
index 469e2b0a536da88c62f2c76a5c96940335bdb928..d0180e297acf72cfec9bd15d73af49099327d92e 100644 (file)
@@ -45,6 +45,17 @@ define Build/dns313-images
        rm -rf $@.tmp
 endef
 
+define Build/wiligear-image
+       $(STAGING_DIR_HOST)/bin/mkfwimage2 \
+               -m GEOS -f 0x30000000 -z \
+               -v $(1).v5.00.SL3512.OpenWrt.00000.000000.000000 \
+               -p Kernel:0x020000:0x100000:0:0:$(IMAGE_KERNEL) \
+               -p Ramdisk:0x120000:0x500000:0:0:$@ \
+               -o $@.new
+
+       mv $@.new $@
+endef
+
 # Create the special NAS4220B and Itian Square One SQ201 image
 # format with the squashfs and overlay inside the "rd.gz" file.
 # We pad it out to 6144K which is the size of the initramfs partition.
@@ -53,15 +64,19 @@ endef
 # there when using OpenWRT. We just use that to create the
 # "sysupgrade" firmware image.
 define Build/nas4220b-sq201-images
-       rm -rf $@-tmp
-       mkdir -p $@-tmp
-       mv $@ $@-tmp/rd.gz
-       dd if=/dev/zero of=$@-tmp/hddapp.tgz bs=6144k count=1
-       cp $(IMAGE_KERNEL) $@-tmp/zImage
-       cp ./ImageInfo-$(1) $@-tmp/ImageInfo
-       (cd $@-tmp; tar --sort=name --owner=0 --group=0 --numeric-owner -czf $@ * \
+       mkdir -p $@.tmp
+
+       mv $@ $@.tmp/rd.gz
+       dd if=/dev/zero of=$@.tmp/hddapp.tgz bs=6144k count=1
+       cp $(IMAGE_KERNEL) $@.tmp/zImage
+       cp ./ImageInfo-$(1) $@.tmp/ImageInfo
+
+       sed -i -e "s/DATESTR/`date +%Y%m%d $(if $(SOURCE_DATE_EPOCH),--date "@$(SOURCE_DATE_EPOCH)")`/g" $@.tmp/ImageInfo
+
+       (cd $@.tmp; tar --sort=name --owner=0 --group=0 --numeric-owner -czf $@ * \
                $(if $(SOURCE_DATE_EPOCH),--mtime="@$(SOURCE_DATE_EPOCH)"))
-       rm -rf $@-tmp
+
+       rm -rf $@.tmp
 endef
 
 # WBD-111 and WBD-222:
@@ -78,14 +93,10 @@ endef
 # All DTB files are prefixed with "gemini-"
 define Device/Default
        PROFILES := Default
-       DEVICE_DTS := $(patsubst %.dtb,%,$(notdir $(wildcard $(if $(IB),$(KDIR),$(DTS_DIR))/*-$(1).dtb)))
        KERNEL_DEPENDS = $$(wildcard $(DTS_DIR)/$$(DEVICE_DTS).dts)
        KERNEL_NAME := zImage
        KERNEL := kernel-bin | append-dtb
-       FILESYSTEMS := squashfs
-       IMAGE_NAME = $$(IMAGE_PREFIX)-$$(1).$$(2)
        BLOCKSIZE := 128k
-       PAGESIZE := 2048
 endef
 
 # A reasonable set of default packages handling the NAS type
@@ -97,62 +108,70 @@ GEMINI_NAS_PACKAGES:=kmod-md-mod kmod-md-linear kmod-md-multipath \
                kmod-nls-utf8 kmod-usb-storage-extras \
                samba36-server mdadm cfdisk fdisk e2fsprogs badblocks
 
-define Device/dlink-dir-685
+define Device/dlink_dir-685
        DEVICE_TITLE := D-Link DIR-685 Xtreme N Storage Router
+       DEVICE_DTS := gemini-dlink-dir-685
        DEVICE_PACKAGES := $(GEMINI_NAS_PACKAGES) \
                        kmod-switch-rtl8366rb swconfig \
-                       rt2800-pci
-       IMAGES := fwupdate.bin
-       IMAGE/fwupdate.bin := dir685-images
+                       kmod-rt2800-pci
+       IMAGES := factory.bin
+       IMAGE/factory.bin := dir685-images
 endef
-TARGET_DEVICES += dlink-dir-685
+TARGET_DEVICES += dlink_dir-685
 
-define Device/dlink-dns-313
+define Device/dlink_dns-313
        DEVICE_TITLE := D-Link DNS-313 1-Bay Network Storage Enclosure
+       DEVICE_DTS := gemini-dlink-dns-313
        DEVICE_PACKAGES := $(GEMINI_NAS_PACKAGES)
-       IMAGES := dns313-bootpart.tar.gz
-       IMAGE/dns313-bootpart.tar.gz := dns313-images
-endef
-TARGET_DEVICES += dlink-dns-313
-
-define Device/nas4220b-sq201
-       ARTIFACTS := zImage
-       ARTIFACT/zImage := append-kernel
-       IMAGES += rd.gz sysupgrade.tar.gz
-       IMAGE/rd.gz := append-rootfs | pad-to 6144k
-       IMAGE/sysupgrade.tar.gz := append-rootfs | pad-to 6144k | nas4220b-sq201-images $(1)
-       DEVICE_PACKAGES := $(GEMINI_NAS_PACKAGES)
+       IMAGES := factory.bin
+       IMAGE/factory.bin := dns313-images
 endef
+TARGET_DEVICES += dlink_dns-313
 
-define Device/nas4220b
-       $(Device/nas4220b-sq201)
-       DEVICE_TITLE := Raidsonic NAS IB-4220-B
-endef
-TARGET_DEVICES += nas4220b
-
-define Device/rut1xx
-       DEVICE_TITLE := Teltonika RUT1xx
+define Device/itian-raidsonic
+       IMAGES := factory.bin
+       IMAGE/factory.bin := append-rootfs | pad-rootfs | pad-to 6144k | \
+               nas4220b-sq201-images $(1)
        DEVICE_PACKAGES := $(GEMINI_NAS_PACKAGES)
 endef
-TARGET_DEVICES += rut1xx
 
-define Device/sq201
-       $(Device/nas4220b-sq201)
+define Device/itian_sq201
+       $(Device/itian-raidsonic)
        DEVICE_TITLE := ITian Square One SQ201
-       DEVICE_PACKAGES += rt61-pci usb2-pci
+       DEVICE_DTS := gemini-sq201
+       DEVICE_PACKAGES += kmod-rt61-pci kmod-usb2-pci
 endef
-TARGET_DEVICES += sq201
+TARGET_DEVICES += itian_sq201
 
-define Device/wbd111
+define Device/raidsonic_ib-4220-b
+       $(Device/itian-raidsonic)
+       DEVICE_TITLE := Raidsonic NAS IB-4220-B
+       DEVICE_DTS := gemini-nas4220b
+endef
+TARGET_DEVICES += raidsonic_ib-4220-b
+
+# The wiliboard images need some changes to be functional and buildable.
+#
+# The dts would need to use the ecoscentric,redboot-fis-partitions partition
+# parser to get the correct partition offsets and size.
+#
+# The mkfwimage2 call need to be adjusted to reflect the real size of kernel
+# and rootfs. It is expected that the OEM firmware adjusts the on flash
+# partition table with the values defined in the image header.
+define Device/wiliboard_wbd111
        DEVICE_TITLE := Wiliboard WBD-111
+       DEVICE_DTS := gemini-wbd111
        KERNEL := kernel-bin | append-dtb | wbd-nops
+       IMAGES := factory.bin
+       IMAGE/factory.bin := append-rootfs | pad-rootfs | wiligear-image "WILI-S.WILIBOARD"
 endef
-TARGET_DEVICES += wbd111
 
-define Device/wbd222
+define Device/wiliboard_wbd222
        DEVICE_TITLE := Wiliboard WBD-222
+       DEVICE_DTS := gemini-wbd222
        KERNEL := kernel-bin | append-dtb | wbd-nops
+       IMAGES := factory.bin
+       IMAGE/factory.bin := append-rootfs | pad-rootfs | wiligear-image "WILI-S.WBD222"
 endef
-TARGET_DEVICES += wbd222
 
 $(eval $(call BuildImage))