remove the old broadcom wl driver for linux 2.4
[openwrt/openwrt.git] / target / linux / generic-2.4 / patches / 621-netfilter_random.patch
index 1ee85be46f4c6ef00d9e79f1a5a55f613d1f3f07..fbc648b1bc011f6afe8ccf829d4691eac73e1023 100644 (file)
@@ -1,6 +1,5 @@
-diff -Naurp linux-2.4.34/Documentation/Configure.help linux-2.4.34.patched/Documentation/Configure.help
---- linux-2.4.34/Documentation/Configure.help  2007-07-08 05:01:42.000000000 +0200
-+++ linux-2.4.34.patched/Documentation/Configure.help  2007-07-08 05:02:26.000000000 +0200
+--- a/Documentation/Configure.help
++++ b/Documentation/Configure.help
 @@ -2914,6 +2914,15 @@ CONFIG_IP_NF_MATCH_MAC
    If you want to compile it as a module, say M here and read
    <file:Documentation/modules.txt>.  If unsure, say `N'.
@@ -17,7 +16,7 @@ diff -Naurp linux-2.4.34/Documentation/Configure.help linux-2.4.34.patched/Docum
  Netfilter MARK match support
  CONFIG_IP_NF_MATCH_MARK
    Netfilter mark matching allows you to match packets based on the
-@@ -3221,6 +3230,7 @@ CONFIG_IP_NF_MATCH_HELPER
+@@ -3229,6 +3238,7 @@ CONFIG_IP_NF_MATCH_HELPER
    If you want to compile it as a module, say M here and read
    Documentation/modules.txt.  If unsure, say `Y'.
  
@@ -25,7 +24,7 @@ diff -Naurp linux-2.4.34/Documentation/Configure.help linux-2.4.34.patched/Docum
  TCPMSS match support
  CONFIG_IP_NF_MATCH_TCPMSS
    This option adds a `tcpmss' match, which allows you to examine the
-@@ -3299,6 +3309,14 @@ CONFIG_IP6_NF_MATCH_MAC
+@@ -3318,6 +3328,14 @@ CONFIG_IP6_NF_MATCH_MAC
    If you want to compile it as a module, say M here and read
    <file:Documentation/modules.txt>.  If unsure, say `N'.
  
@@ -40,9 +39,8 @@ diff -Naurp linux-2.4.34/Documentation/Configure.help linux-2.4.34.patched/Docum
  length match support
  CONFIG_IP6_NF_MATCH_LENGTH
    This option allows you to match the length of a packet against a
-diff -Naurp linux-2.4.34/include/linux/netfilter_ipv4/ipt_random.h linux-2.4.34.patched/include/linux/netfilter_ipv4/ipt_random.h
---- linux-2.4.34/include/linux/netfilter_ipv4/ipt_random.h     1970-01-01 01:00:00.000000000 +0100
-+++ linux-2.4.34.patched/include/linux/netfilter_ipv4/ipt_random.h     2007-07-08 05:02:26.000000000 +0200
+--- /dev/null
++++ b/include/linux/netfilter_ipv4/ipt_random.h
 @@ -0,0 +1,11 @@
 +#ifndef _IPT_RAND_H
 +#define _IPT_RAND_H
@@ -55,9 +53,8 @@ diff -Naurp linux-2.4.34/include/linux/netfilter_ipv4/ipt_random.h linux-2.4.34.
 +};
 +
 +#endif /*_IPT_RAND_H*/
-diff -Naurp linux-2.4.34/include/linux/netfilter_ipv6/ip6t_random.h linux-2.4.34.patched/include/linux/netfilter_ipv6/ip6t_random.h
---- linux-2.4.34/include/linux/netfilter_ipv6/ip6t_random.h    1970-01-01 01:00:00.000000000 +0100
-+++ linux-2.4.34.patched/include/linux/netfilter_ipv6/ip6t_random.h    2007-07-08 05:02:26.000000000 +0200
+--- /dev/null
++++ b/include/linux/netfilter_ipv6/ip6t_random.h
 @@ -0,0 +1,11 @@
 +#ifndef _IP6T_RAND_H
 +#define _IP6T_RAND_H
@@ -70,20 +67,18 @@ diff -Naurp linux-2.4.34/include/linux/netfilter_ipv6/ip6t_random.h linux-2.4.34
 +};
 +
 +#endif /*_IP6T_RAND_H*/
-diff -Naurp linux-2.4.34/net/ipv4/netfilter/Config.in linux-2.4.34.patched/net/ipv4/netfilter/Config.in
---- linux-2.4.34/net/ipv4/netfilter/Config.in  2007-07-08 05:01:42.000000000 +0200
-+++ linux-2.4.34.patched/net/ipv4/netfilter/Config.in  2007-07-08 05:03:32.000000000 +0200
+--- a/net/ipv4/netfilter/Config.in
++++ b/net/ipv4/netfilter/Config.in
 @@ -32,6 +32,7 @@ if [ "$CONFIG_IP_NF_IPTABLES" != "n" ]; 
    dep_tristate '  netfilter MARK match support' CONFIG_IP_NF_MATCH_MARK $CONFIG_IP_NF_IPTABLES
    dep_tristate '  Multiple port match support' CONFIG_IP_NF_MATCH_MULTIPORT $CONFIG_IP_NF_IPTABLES
    dep_tristate '  TOS match support' CONFIG_IP_NF_MATCH_TOS $CONFIG_IP_NF_IPTABLES
 +  dep_tristate '  random match support' CONFIG_IP_NF_MATCH_RANDOM $CONFIG_IP_NF_IPTABLES
-   dep_tristate '  TIME match support (EXPERIMENTAL)' CONFIG_IP_NF_MATCH_TIME $CONFIG_IP_NF_IPTABLES
    dep_tristate '  condition match support' CONFIG_IP_NF_MATCH_CONDITION $CONFIG_IP_NF_IPTABLES
    dep_tristate '  recent match support' CONFIG_IP_NF_MATCH_RECENT $CONFIG_IP_NF_IPTABLES
-diff -Naurp linux-2.4.34/net/ipv4/netfilter/ipt_random.c linux-2.4.34.patched/net/ipv4/netfilter/ipt_random.c
---- linux-2.4.34/net/ipv4/netfilter/ipt_random.c       1970-01-01 01:00:00.000000000 +0100
-+++ linux-2.4.34.patched/net/ipv4/netfilter/ipt_random.c       2007-07-08 05:02:26.000000000 +0200
+   dep_tristate '  ECN match support' CONFIG_IP_NF_MATCH_ECN $CONFIG_IP_NF_IPTABLES
+--- /dev/null
++++ b/net/ipv4/netfilter/ipt_random.c
 @@ -0,0 +1,96 @@
 +/*
 +  This is a module which is used for a "random" match support.
@@ -181,11 +176,10 @@ diff -Naurp linux-2.4.34/net/ipv4/netfilter/ipt_random.c linux-2.4.34.patched/ne
 +
 +module_init(init);
 +module_exit(fini);
-diff -Naurp linux-2.4.34/net/ipv4/netfilter/Makefile linux-2.4.34.patched/net/ipv4/netfilter/Makefile
---- linux-2.4.34/net/ipv4/netfilter/Makefile   2007-07-08 05:01:42.000000000 +0200
-+++ linux-2.4.34.patched/net/ipv4/netfilter/Makefile   2007-07-08 05:02:26.000000000 +0200
-@@ -102,6 +102,8 @@ obj-$(CONFIG_IP_NF_MATCH_TOS) += ipt_tos
- obj-$(CONFIG_IP_NF_MATCH_TIME) += ipt_time.o
+--- a/net/ipv4/netfilter/Makefile
++++ b/net/ipv4/netfilter/Makefile
+@@ -93,6 +93,8 @@ obj-$(CONFIG_IP_NF_MATCH_OWNER) += ipt_o
+ obj-$(CONFIG_IP_NF_MATCH_TOS) += ipt_tos.o
  obj-$(CONFIG_IP_NF_MATCH_CONDITION) += ipt_condition.o
  
 +obj-$(CONFIG_IP_NF_MATCH_RANDOM) += ipt_random.o
@@ -193,9 +187,8 @@ diff -Naurp linux-2.4.34/net/ipv4/netfilter/Makefile linux-2.4.34.patched/net/ip
  obj-$(CONFIG_IP_NF_MATCH_RECENT) += ipt_recent.o
  
  obj-$(CONFIG_IP_NF_MATCH_ECN) += ipt_ecn.o
-diff -Naurp linux-2.4.34/net/ipv6/netfilter/Config.in linux-2.4.34.patched/net/ipv6/netfilter/Config.in
---- linux-2.4.34/net/ipv6/netfilter/Config.in  2007-07-08 05:01:42.000000000 +0200
-+++ linux-2.4.34.patched/net/ipv6/netfilter/Config.in  2007-07-08 05:02:26.000000000 +0200
+--- a/net/ipv6/netfilter/Config.in
++++ b/net/ipv6/netfilter/Config.in
 @@ -19,6 +19,7 @@ if [ "$CONFIG_IP6_NF_IPTABLES" != "n" ];
    dep_tristate '  limit match support' CONFIG_IP6_NF_MATCH_LIMIT $CONFIG_IP6_NF_IPTABLES
    dep_tristate '  condition match support' CONFIG_IP6_NF_MATCH_CONDITION $CONFIG_IP6_NF_IPTABLES
@@ -204,9 +197,8 @@ diff -Naurp linux-2.4.34/net/ipv6/netfilter/Config.in linux-2.4.34.patched/net/i
    if [ "$CONFIG_EXPERIMENTAL" = "y" ]; then
      dep_tristate '  Routing header match support (EXPERIMENTAL)' CONFIG_IP6_NF_MATCH_RT $CONFIG_IP6_NF_IPTABLES
    fi
-diff -Naurp linux-2.4.34/net/ipv6/netfilter/ip6t_random.c linux-2.4.34.patched/net/ipv6/netfilter/ip6t_random.c
---- linux-2.4.34/net/ipv6/netfilter/ip6t_random.c      1970-01-01 01:00:00.000000000 +0100
-+++ linux-2.4.34.patched/net/ipv6/netfilter/ip6t_random.c      2007-07-08 05:02:26.000000000 +0200
+--- /dev/null
++++ b/net/ipv6/netfilter/ip6t_random.c
 @@ -0,0 +1,97 @@
 +/*
 +  This is a module which is used for a "random" match support.
@@ -305,9 +297,8 @@ diff -Naurp linux-2.4.34/net/ipv6/netfilter/ip6t_random.c linux-2.4.34.patched/n
 +
 +module_init(init);
 +module_exit(fini);
-diff -Naurp linux-2.4.34/net/ipv6/netfilter/Makefile linux-2.4.34.patched/net/ipv6/netfilter/Makefile
---- linux-2.4.34/net/ipv6/netfilter/Makefile   2007-07-08 05:01:42.000000000 +0200
-+++ linux-2.4.34.patched/net/ipv6/netfilter/Makefile   2007-07-08 05:02:26.000000000 +0200
+--- a/net/ipv6/netfilter/Makefile
++++ b/net/ipv6/netfilter/Makefile
 @@ -32,6 +32,7 @@ obj-$(CONFIG_IP6_NF_TARGET_MARK) += ip6t
  obj-$(CONFIG_IP6_NF_TARGET_IMQ) += ip6t_IMQ.o
  obj-$(CONFIG_IP6_NF_QUEUE) += ip6_queue.o