Update gpiommc to use configfs
[openwrt/openwrt.git] / target / linux / generic-2.6 / patches-2.6.25 / 140-netfilter_time.patch
index a77f04c244b6625fd8fa393ea273ea73d84e95ef..ba6b5dc3202fef3e0ee6b4e2786541dbb357b4de 100644 (file)
@@ -1,7 +1,5 @@
-Index: linux-2.6.23-rc6/include/linux/netfilter_ipv4/ipt_time.h
-===================================================================
---- /dev/null  1970-01-01 00:00:00.000000000 +0000
-+++ linux-2.6.23-rc6/include/linux/netfilter_ipv4/ipt_time.h   2007-09-21 16:24:02.000000000 +0800
+--- /dev/null
++++ b/include/linux/netfilter_ipv4/ipt_time.h
 @@ -0,0 +1,18 @@
 +#ifndef __ipt_time_h_included__
 +#define __ipt_time_h_included__
@@ -21,10 +19,8 @@ Index: linux-2.6.23-rc6/include/linux/netfilter_ipv4/ipt_time.h
 +
 +
 +#endif /* __ipt_time_h_included__ */
-Index: linux-2.6.23-rc6/net/ipv4/netfilter/ipt_time.c
-===================================================================
---- /dev/null  1970-01-01 00:00:00.000000000 +0000
-+++ linux-2.6.23-rc6/net/ipv4/netfilter/ipt_time.c     2007-09-21 16:24:02.000000000 +0800
+--- /dev/null
++++ b/net/ipv4/netfilter/ipt_time.c
 @@ -0,0 +1,180 @@
 +/*
 +  This is a module which is used for time matching
@@ -122,7 +118,7 @@ Index: linux-2.6.23-rc6/net/ipv4/netfilter/ipt_time.c
 +
 +      /* First, check that we are in the correct hooks */
 +      if (hook_mask
-+            & ~((1 << NF_IP_PRE_ROUTING) | (1 << NF_IP_LOCAL_IN) | (1 << NF_IP_FORWARD) | (1 << NF_IP_LOCAL_OUT)))
++            & ~((1 << NF_INET_PRE_ROUTING) | (1 << NF_INET_LOCAL_IN) | (1 << NF_INET_FORWARD) | (1 << NF_INET_LOCAL_OUT)))
 +      {
 +              printk("ipt_time: error, only valid for PRE_ROUTING, LOCAL_IN, FORWARD and OUTPUT)\n");
 +              return 0;
@@ -206,13 +202,11 @@ Index: linux-2.6.23-rc6/net/ipv4/netfilter/ipt_time.c
 +      r->tm_mon=i;
 +      r->tm_mday=work-__spm[i]+1;
 +}
-Index: linux-2.6.23-rc6/net/ipv4/netfilter/Kconfig
-===================================================================
---- linux-2.6.23-rc6.orig/net/ipv4/netfilter/Kconfig   2007-09-21 16:24:01.000000000 +0800
-+++ linux-2.6.23-rc6/net/ipv4/netfilter/Kconfig        2007-09-21 16:24:02.000000000 +0800
-@@ -96,6 +96,22 @@
-         To compile it as a module, choose M here.  If unsure, say N.
+--- a/net/ipv4/netfilter/Kconfig
++++ b/net/ipv4/netfilter/Kconfig
+@@ -63,6 +63,22 @@
+       help
+         Module for matching traffic of various Peer-to-Peer applications
  
 +
 +config IP_NF_MATCH_TIME
@@ -231,14 +225,12 @@ Index: linux-2.6.23-rc6/net/ipv4/netfilter/Kconfig
 +
 +
  config IP_NF_MATCH_RECENT
-       tristate "recent match support"
+       tristate '"recent" match support'
        depends on IP_NF_IPTABLES
-Index: linux-2.6.23-rc6/net/ipv4/netfilter/Makefile
-===================================================================
---- linux-2.6.23-rc6.orig/net/ipv4/netfilter/Makefile  2007-09-21 16:24:01.000000000 +0800
-+++ linux-2.6.23-rc6/net/ipv4/netfilter/Makefile       2007-09-21 16:24:02.000000000 +0800
-@@ -50,6 +50,7 @@
- obj-$(CONFIG_IP_NF_MATCH_TOS) += ipt_tos.o
+--- a/net/ipv4/netfilter/Makefile
++++ b/net/ipv4/netfilter/Makefile
+@@ -47,6 +47,7 @@
+ obj-$(CONFIG_IP_NF_MATCH_RECENT) += ipt_recent.o
  obj-$(CONFIG_IP_NF_MATCH_TTL) += ipt_ttl.o
  obj-$(CONFIG_IP_NF_MATCH_SET) += ipt_set.o
 +obj-$(CONFIG_IP_NF_MATCH_TIME) += ipt_time.o