kernel: fix kmemleak warnings introduced in 305-mips_module_reloc.patch
[openwrt/openwrt.git] / target / linux / generic / pending-4.19 / 305-mips_module_reloc.patch
index 609a96db492e4fafa03edd2c228dbe7b5dcdb244..1f98dfd8efb97cd519801c3fbebe9c152dda7ca3 100644 (file)
@@ -11,7 +11,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
 
 --- a/arch/mips/Makefile
 +++ b/arch/mips/Makefile
-@@ -93,8 +93,18 @@ all-$(CONFIG_SYS_SUPPORTS_ZBOOT)+= vmlin
+@@ -94,8 +94,18 @@ all-$(CONFIG_SYS_SUPPORTS_ZBOOT)+= vmlin
  cflags-y                      += -G 0 -mno-abicalls -fno-pic -pipe -mno-branch-likely
  cflags-y                      += -msoft-float
  LDFLAGS_vmlinux                       += -G 0 -static -n -nostdlib
@@ -46,7 +46,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
  typedef uint8_t Elf64_Byte;           /* Type for a 8-bit quantity.  */
 --- a/arch/mips/kernel/module.c
 +++ b/arch/mips/kernel/module.c
-@@ -44,14 +44,221 @@ struct mips_hi16 {
+@@ -44,14 +44,224 @@ struct mips_hi16 {
  static LIST_HEAD(dbe_list);
  static DEFINE_SPINLOCK(dbe_lock);
  
@@ -187,6 +187,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
 +      if (!ptr)
 +              return vmalloc(size);
 +
++      kmemleak_alloc(ptr, size, 1, GFP_KERNEL);
 +      return ptr;
 +#endif
  }
@@ -203,10 +204,12 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
 +/* Free memory returned from module_alloc */
 +void module_memfree(void *module_region)
 +{
-+      if (is_phys_addr(module_region))
++      if (is_phys_addr(module_region)) {
++              kmemleak_free(module_region);
 +              free_phys(module_region);
-+      else
++      } else {
 +              vfree(module_region);
++      }
 +}
 +
 +static void *__module_alloc(int size, bool phys)
@@ -269,7 +272,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
  
  static int apply_r_mips_none(struct module *me, u32 *location,
                             u32 base, Elf_Addr v, bool rela)
-@@ -67,9 +274,40 @@ static int apply_r_mips_32(struct module
+@@ -67,9 +277,40 @@ static int apply_r_mips_32(struct module
        return 0;
  }
  
@@ -310,7 +313,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
        if (v % 4) {
                pr_err("module %s: dangerous R_MIPS_26 relocation\n",
                       me->name);
-@@ -77,13 +315,17 @@ static int apply_r_mips_26(struct module
+@@ -77,13 +318,17 @@ static int apply_r_mips_26(struct module
        }
  
        if ((v & 0xf0000000) != (((unsigned long)location + 4) & 0xf0000000)) {
@@ -332,7 +335,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
  
        return 0;
  }
-@@ -459,9 +701,36 @@ int module_finalize(const Elf_Ehdr *hdr,
+@@ -459,9 +704,36 @@ int module_finalize(const Elf_Ehdr *hdr,
                list_add(&me->arch.dbe_list, &dbe_list);
                spin_unlock_irq(&dbe_lock);
        }