kernel: bump 3.18 to 3.18.123
[openwrt/openwrt.git] / target / linux / imx6 / Makefile
index eed8088460a887cda719a0efb125c0c8a3f0d3c2..73512ca986374d8a73d032dd767c7931a0d90f55 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2013 OpenWrt.org
+# Copyright (C) 2013-2014 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -8,19 +8,18 @@ include $(TOPDIR)/rules.mk
 
 ARCH:=arm
 BOARD:=imx6
-BOARDNAME:=Freescale i.MX 6 Series
-FEATURES:=audio display gpio pcie usb usbgadget squashfs targz
+BOARDNAME:=Freescale i.MX 6
+FEATURES:=audio display fpu gpio pcie rtc usb usbgadget squashfs targz nand ubifs boot-part rootfs-part
 CPU_TYPE:=cortex-a9
-CPU_SUBTYPE:=vfpv3
+CPU_SUBTYPE:=neon
 MAINTAINER:=Luka Perkov <luka@openwrt.org>
 
-LINUX_VERSION:=3.10.12
+KERNEL_PATCHVER:=4.14
 
 include $(INCLUDE_DIR)/target.mk
 
-KERNELNAME:="zImage dtbs"
+KERNELNAME:=zImage dtbs
 
-DEFAULT_PACKAGES += \
-       kmod-usb-chipidea kmod-usb-mxs-phy uboot-envtools
+DEFAULT_PACKAGES += uboot-envtools mkf2fs e2fsprogs
 
 $(eval $(call BuildTarget))