imx6: move to Linux 4.9 kernel
[openwrt/openwrt.git] / target / linux / imx6 / Makefile
index 4d46c3ea795d028f01dbef87ed676c8ebeecb76c..ae6a9b0d5d79b232f1309396552fe611dcf60aa8 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2013 OpenWrt.org
+# Copyright (C) 2013-2014 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -8,16 +8,18 @@ include $(TOPDIR)/rules.mk
 
 ARCH:=arm
 BOARD:=imx6
-BOARDNAME:=Freescale i.MX 6 Series
-FEATURES:=audio display fpu gpio pcie rtc usb usbgadget squashfs targz ubifs
+BOARDNAME:=Freescale i.MX 6
+FEATURES:=audio display fpu gpio pcie rtc usb usbgadget squashfs targz nand ubifs
 CPU_TYPE:=cortex-a9
 CPU_SUBTYPE:=neon
 MAINTAINER:=Luka Perkov <luka@openwrt.org>
 
-LINUX_VERSION:=3.10.36
+KERNEL_PATCHVER:=4.9
 
 include $(INCLUDE_DIR)/target.mk
 
-KERNELNAME:="zImage dtbs"
+KERNELNAME:=zImage dtbs
+
+DEFAULT_PACKAGES += uboot-envtools
 
 $(eval $(call BuildTarget))