imx6: refresh and update target kernel configs
[openwrt/openwrt.git] / target / linux / imx6 / image / Makefile
index 7608bd6d8c28416c236c09e1052382bd538106f8..5f8e5f1c04f35772eba782a0d8d1ce1f08969961 100644 (file)
@@ -9,7 +9,7 @@ include $(INCLUDE_DIR)/image.mk
 # Images
 #################################################
 
-DEVICE_VARS += MKUBIFS_OPTS UBOOT BOOT_SCRIPT
+DEVICE_VARS += MKUBIFS_OPTS UBOOT
 
 define Build/boot-overlay
        rm -rf $@.boot
@@ -49,13 +49,6 @@ define Build/bootfs.tar.gz
                -czvf $@ .
 endef
 
-define Build/boot-scr
-       mkimage -A arm -O linux -T script -C none -a 0 -e 0 \
-       -n '$(DEVICE_ID) OpenWrt bootscript' \
-       -d ./bootscript-$(DEVICE_NAME) \
-       $(BIN_DIR)/boot.scr
-endef
-
 define Build/recovery-scr
        mkimage -A arm -O linux -T script -C none -a 0 -e 0 \
        -n '$(DEVICE_ID) OpenWrt recovery bootscript' \
@@ -82,7 +75,7 @@ define Build/imx6-combined-image
 
        mkimage -A arm -O linux -T script -C none -a 0 -e 0 \
                -n '$(DEVICE_ID) OpenWrt bootscript' \
-               -d $(BOOT_SCRIPT) \
+               -d bootscript-$(DEVICE_NAME) \
                $@.boot/boot.scr
 
        cp $@ $@.fs
@@ -127,10 +120,11 @@ define Device/Default
   IMAGES :=
 endef
 
-define Device/ventana
+define Device/gateworks_ventana
   DEVICE_VENDOR := Gateworks
   DEVICE_MODEL := Ventana family
   DEVICE_VARIANT := normal NAND flash
+  DEVICE_NAME := ventana
   DEVICE_DTS:= \
        imx6dl-gw51xx \
        imx6dl-gw52xx \
@@ -157,60 +151,51 @@ define Device/ventana
        imx6q-gw5910 \
        imx6q-gw5912 \
        imx6q-gw5913
-  DEVICE_PACKAGES := kmod-sky2 kmod-sound-core kmod-sound-soc-imx kmod-sound-soc-imx-sgtl5000 \
-       kmod-can kmod-can-flexcan kmod-can-raw \
-       kmod-hwmon-gsc \
-       kmod-leds-gpio kmod-pps-gpio \
-       kobs-ng
+  DEVICE_PACKAGES := kmod-sky2 kmod-sound-core kmod-sound-soc-imx \
+       kmod-sound-soc-imx-sgtl5000 kmod-can kmod-can-flexcan kmod-can-raw \
+       kmod-hwmon-gsc kmod-leds-gpio kmod-pps-gpio kobs-ng
   KERNEL += | boot-overlay
   IMAGES := nand.ubi bootfs.tar.gz dtb
-  UBINIZE_PARTS = boot=$$(KDIR_KERNEL_IMAGE).boot.ubifs=15
-  BOOT_SCRIPT := bootscript-ventana
   IMAGE/nand.ubi := append-ubi
   IMAGE/bootfs.tar.gz := bootfs.tar.gz
   IMAGE/dtb := install-dtb
+  UBINIZE_PARTS = boot=$$(KDIR_KERNEL_IMAGE).boot.ubifs=15
   PAGESIZE := 2048
   BLOCKSIZE := 128k
   MKUBIFS_OPTS := -m $$(PAGESIZE) -e 124KiB
 endef
-TARGET_DEVICES += ventana
+TARGET_DEVICES += gateworks_ventana
 
-define Device/ventana-large
-  $(Device/ventana)
+define Device/gateworks_ventana-large
+  $(Device/gateworks_ventana)
   DEVICE_VARIANT := large NAND flash
-  DEVICE_NAME := ventana
   IMAGES := nand.ubi
   PAGESIZE := 4096
   BLOCKSIZE := 256k
   MKUBIFS_OPTS := -m $$(PAGESIZE) -e 248KiB
 endef
-TARGET_DEVICES += ventana-large
-
-define Device/wandboard
-  DEVICE_VENDOR := Wandboard
-  DEVICE_MODEL := Dual
-  DEVICE_DTS := imx6dl-wandboard
-endef
-TARGET_DEVICES += wandboard
+TARGET_DEVICES += gateworks_ventana-large
 
-define Device/cubox-i
+define Device/solidrun_cubox-i
   DEVICE_VENDOR := SolidRun
   DEVICE_MODEL := CuBox-i
+  DEVICE_DTS := \
+       imx6q-cubox-i \
+       imx6dl-cubox-i \
+       imx6q-hummingboard \
+       imx6dl-hummingboard
+  DEVICE_PACKAGES := kmod-drm-imx kmod-drm-imx-hdmi kmod-usb-hid
+  UBOOT := mx6cuboxi
   KERNEL := kernel-bin
   KERNEL_SUFFIX := -zImage
-  UBOOT := mx6cuboxi
-  BOOT_SCRIPT := bootscript-cubox
-  DEVICE_NAME := cubox
-  DEVICE_PACKAGES := kmod-drm-imx kmod-drm-imx-hdmi kmod-usb-hid
-  DEVICE_DTS := imx6q-cubox-i imx6dl-cubox-i imx6q-hummingboard imx6dl-hummingboard
-  IMAGES := combined.bin dtb
   FILESYSTEMS := squashfs
+  IMAGES := combined.bin dtb
   IMAGE/combined.bin := append-rootfs | pad-extra 128k | imx6-sdcard
   IMAGE/dtb := install-dtb
 endef
-TARGET_DEVICES += cubox-i
+TARGET_DEVICES += solidrun_cubox-i
 
-define Device/apalis
+define Device/toradex_apalis
   DEVICE_VENDOR := Toradex
   DEVICE_MODEL := Apalis family
   SUPPORTED_DEVICES := apalis,ixora apalis,eval
@@ -222,7 +207,6 @@ define Device/apalis
        kmod-can kmod-can-flexcan kmod-can-raw \
        kmod-leds-gpio kmod-gpio-button-hotplug \
        kmod-pps-gpio kmod-rtc-ds1307
-  BOOT_SCRIPT := bootscript-apalis
   FILESYSTEMS := squashfs
   IMAGES := combined.bin sysupgrade.bin
   DEVICE_IMG_NAME = $$(DEVICE_IMG_PREFIX)-$$(1).$$(2)
@@ -231,6 +215,13 @@ define Device/apalis
   ARTIFACTS := recovery.scr
   ARTIFACT/recovery.scr := recovery-scr
 endef
-TARGET_DEVICES += apalis
+TARGET_DEVICES += toradex_apalis
+
+define Device/wandboard_dual
+  DEVICE_VENDOR := Wandboard
+  DEVICE_MODEL := Dual
+  DEVICE_DTS := imx6dl-wandboard
+endef
+TARGET_DEVICES += wandboard_dual
 
 $(eval $(call BuildImage))