ipq40xx: add Edgecore ECW5211 support
[openwrt/openwrt.git] / target / linux / ipq40xx / image / Makefile
index 51e8bcc7e36df300debbea28845e70fb06388e60..127af99ce582b36fd4e7b48e993a581193102ed2 100644 (file)
@@ -344,6 +344,18 @@ define Device/dlink_dap-2610
 endef
 TARGET_DEVICES += dlink_dap-2610
 
+define Device/edgecore_ecw5211
+       $(call Device/FitImage)
+       $(call Device/UbiFit)
+       DEVICE_TITLE := Edgecore ECW5211
+       BLOCKSIZE := 128k
+       PAGESIZE := 2048
+       DEVICE_DTS_CONFIG := config@ap.dk01.1-c2
+       DEVICE_DTS := qcom-ipq4018-ecw5211
+       DEVICE_PACKAGES := ipq-wifi-edgecore_ecw5211 kmod-tpm-i2c-atmel kmod-usb-acm uboot-envtools
+endef
+TARGET_DEVICES += edgecore_ecw5211
+
 define Device/engenius_eap1300
        $(call Device/FitImage)
        DEVICE_VENDOR := EnGenius