ipq40xx: Add support for Unielec U4019
[openwrt/openwrt.git] / target / linux / ipq40xx / image / Makefile
index 4572ab461db19bdc81a73d9a03891e1db0b7f275..8907eb756b3544ace2af753d6dedf8c49467f94b 100644 (file)
@@ -404,6 +404,19 @@ define Device/qxwlan_e2600ac-c2
 endef
 TARGET_DEVICES += qxwlan_e2600ac-c2
 
+define Device/unielec_u4019-32m
+       $(call Device/FitImage)
+       DEVICE_VENDOR := Unielec
+       DEVICE_MODEL := U4019 (32M)
+       BOARD_NAME := u4019-32m
+       DEVICE_DTS := qcom-ipq4019-unielec-u4019-32m
+       KERNEL_SIZE := 4096k
+       IMAGE_SIZE := 31232k
+       IMAGES := sysupgrade.bin
+       IMAGE/sysupgrade.bin := append-kernel | append-rootfs | pad-rootfs | append-metadata
+endef
+TARGET_DEVICES += unielec_u4019-32m
+
 define Device/zyxel_nbg6617
        $(call Device/FitImageLzma)
        DEVICE_VENDOR := ZyXEL