ipq40xx: add eva-image for FRITZ!Box 4040
[openwrt/openwrt.git] / target / linux / ipq40xx / image / Makefile
index be396f92dacf73be38870e9a5331d27617abb0de..8ba2697e4ff91aa7da056528e37a56d33f512093 100644 (file)
@@ -80,7 +80,10 @@ define Device/avm_fritzbox-4040
        BOARD_NAME := fritz4040
        DEVICE_TITLE := AVM Fritz!Box 4040
        IMAGE_SIZE := 29753344
-       IMAGES = sysupgrade.bin
+       UBOOT_PATH := $$(BIN_DIR)/u-boot-fritz4040/uboot-fritz4040.bin
+       UBOOT_PARTITION_SIZE := 524288
+       IMAGES = eva.bin sysupgrade.bin
+       IMAGE/eva.bin := append-uboot | pad-to $$$$(UBOOT_PARTITION_SIZE) | append-kernel | append-rootfs | pad-rootfs
        IMAGE/sysupgrade.bin := append-kernel | append-rootfs | pad-rootfs | append-metadata
        DEVICE_PACKAGES := fritz-tffs fritz-caldata u-boot-fritz4040
 endef