ipq40xx: add RT-AC2200 alternative name to RT-AC42U/RT-ACRH17
[openwrt/openwrt.git] / target / linux / ipq40xx / image / generic.mk
index b22d261d659a73bb8503a370ca43fa53a77077d5..5eac14e0aedcd8fc7f7fcbe274fcdcae8df04a2b 100644 (file)
@@ -214,6 +214,8 @@ define Device/asus_rt-ac42u
        DEVICE_MODEL := RT-AC42U
        DEVICE_ALT0_VENDOR := ASUS
        DEVICE_ALT0_MODEL := RT-ACRH17
+       DEVICE_ALT1_VENDOR := ASUS
+       DEVICE_ALT1_MODEL := RT-AC2200
        SOC := qcom-ipq4019
        BLOCKSIZE := 128k
        PAGESIZE := 2048
@@ -269,6 +271,8 @@ define Device/avm_fritzbox-7530
        $(call Device/FitImageLzma)
        DEVICE_VENDOR := AVM
        DEVICE_MODEL := FRITZ!Box 7530
+       DEVICE_ALT0_VENDOR := AVM
+       DEVICE_ALT0_MODEL := FRITZ!Box 7520
        SOC := qcom-ipq4019
        DEVICE_PACKAGES := fritz-caldata fritz-tffs-nand
 endef
@@ -928,7 +932,7 @@ define Device/qxwlan_e2600ac-c1
        KERNEL_SIZE := 4096k
        IMAGE_SIZE := 31232k
        IMAGE/sysupgrade.bin := append-kernel | append-rootfs | pad-rootfs | append-metadata
-       DEVICE_PACKAGES := ipq-wifi-qxwlan_e2600ac
+       DEVICE_PACKAGES := ipq-wifi-qxwlan_e2600ac-c1
        DEFAULT := n
 endef
 TARGET_DEVICES += qxwlan_e2600ac-c1
@@ -943,7 +947,7 @@ define Device/qxwlan_e2600ac-c2
        KERNEL_INSTALL := 1
        BLOCKSIZE := 128k
        PAGESIZE := 2048
-       DEVICE_PACKAGES := ipq-wifi-qxwlan_e2600ac
+       DEVICE_PACKAGES := ipq-wifi-qxwlan_e2600ac-c2
 endef
 TARGET_DEVICES += qxwlan_e2600ac-c2
 
@@ -963,6 +967,19 @@ define Device/teltonika_rutx10
 endef
 TARGET_DEVICES += teltonika_rutx10
 
+define Device/tel_x1pro
+       $(call Device/FitImage)
+       DEVICE_VENDOR := Telco
+       DEVICE_MODEL := X1 Pro
+       SOC := qcom-ipq4019
+       KERNEL_SIZE := 4096k
+       IMAGE_SIZE := 31232k
+       IMAGE/sysupgrade.bin := append-kernel | append-rootfs | pad-rootfs | append-metadata
+       DEVICE_PACKAGES := kmod-usb-net-qmi-wwan kmod-usb-serial-option uqmi
+       DEFAULT := n
+endef
+TARGET_DEVICES += tel_x1pro
+
 define Device/unielec_u4019-32m
        $(call Device/FitImage)
        DEVICE_VENDOR := Unielec
@@ -977,6 +994,19 @@ define Device/unielec_u4019-32m
 endef
 TARGET_DEVICES += unielec_u4019-32m
 
+define Device/zte_mf286d
+       $(call Device/FitzImage)
+       DEVICE_VENDOR := ZTE
+       DEVICE_MODEL := MF286D
+       SOC := qcom-ipq4019
+       DEVICE_DTS_CONFIG := config@ap.dk04.1-c1
+       BLOCKSIZE := 128k
+       PAGESIZE := 2048
+       KERNEL_IN_UBI := 1
+       DEVICE_PACKAGES := ipq-wifi-zte_mf286d kmod-usb-net-qmi-wwan kmod-usb-serial-option uqmi
+endef
+TARGET_DEVICES += zte_mf286d
+
 define Device/zyxel_nbg6617
        $(call Device/FitImageLzma)
        DEVICE_VENDOR := ZyXEL