ipq806x: add GSBI1 node to DTSI
[openwrt/openwrt.git] / target / linux / ipq806x / Makefile
index 55a0d72f7ddd04ba0b669ec628d71302e68975d3..69d3aa1e569d79a9436bf14035063986cc12c5e4 100644 (file)
@@ -5,14 +5,22 @@ include $(TOPDIR)/rules.mk
 ARCH:=arm
 BOARD:=ipq806x
 BOARDNAME:=Qualcomm Atheros IPQ806X
-FEATURES:=squashfs
-CPU_TYPE:=cortex-a7
-MAINTAINER:=John Crispin <blogic@openwrt.org>
+FEATURES:=squashfs nand fpu ramdisk
+CPU_TYPE:=cortex-a15
+CPU_SUBTYPE:=neon-vfpv4
+SUBTARGETS:=generic
 
-LINUX_VERSION:=3.14.18
+KERNEL_PATCHVER:=5.4
 
-KERNELNAME:=Image dtbs
+KERNELNAME:=zImage Image dtbs
 
 include $(INCLUDE_DIR)/target.mk
+DEFAULT_PACKAGES += \
+       kmod-leds-gpio kmod-gpio-button-hotplug swconfig \
+       kmod-ata-ahci kmod-ata-ahci-platform \
+       kmod-usb-ohci kmod-usb2 kmod-usb-ledtrig-usbport \
+       kmod-phy-qcom-ipq806x-usb kmod-usb3 kmod-usb-dwc3-qcom \
+       kmod-ath10k-ct wpad-basic-wolfssl \
+       uboot-envtools
 
 $(eval $(call BuildTarget))