ipq806x: add ramdisk feature
[openwrt/openwrt.git] / target / linux / ipq806x / Makefile
index 7521e971ef0472c3e399c92176bb9419d066e190..cd0e8b82ea31645a9dd1d3dcf4a61a807c0db543 100644 (file)
@@ -5,13 +5,22 @@ include $(TOPDIR)/rules.mk
 ARCH:=arm
 BOARD:=ipq806x
 BOARDNAME:=Qualcomm Atheros IPQ806X
-FEATURES:=squashfs
-CPU_TYPE:=cortex-a7
+FEATURES:=squashfs nand fpu ramdisk
+CPU_TYPE:=cortex-a15
+CPU_SUBTYPE:=neon-vfpv4
+MAINTAINER:=John Crispin <john@phrozen.org>
 
-LINUX_VERSION:=3.14.12
+KERNEL_PATCHVER:=4.14
 
-KERNELNAME="Image dtbs"
+KERNELNAME:=zImage Image dtbs
 
 include $(INCLUDE_DIR)/target.mk
+DEFAULT_PACKAGES += \
+       kmod-leds-gpio kmod-gpio-button-hotplug swconfig \
+       kmod-ata-core kmod-ata-ahci kmod-ata-ahci-platform \
+       kmod-usb-core kmod-usb-ohci kmod-usb2 kmod-usb-ledtrig-usbport \
+       kmod-usb3 kmod-usb-dwc3-of-simple kmod-usb-phy-qcom-dwc3 \
+       kmod-ath10k-ct wpad-basic \
+       uboot-envtools
 
 $(eval $(call BuildTarget))