ipq806x: increase kernel partition size for the Netgear Nighthawk X4 R7500v2
[openwrt/openwrt.git] / target / linux / ipq806x / image / Makefile
index 4932040735b4a77bc2cbd81400ee7235d4e892e5..68b039b3aecc607a2b41e2556edadeb2a69994d5 100644 (file)
@@ -34,8 +34,8 @@ endef
 
 define Device/UbiFit
        KERNEL_IN_UBI := 1
-       IMAGES := nand-factory.ubi nand-sysupgrade.bin
-       IMAGE/nand-factory.ubi := append-ubi
+       IMAGES := nand-factory.bin nand-sysupgrade.bin
+       IMAGE/nand-factory.bin := append-ubi
        IMAGE/nand-sysupgrade.bin := sysupgrade-tar | append-metadata
 endef
 
@@ -47,8 +47,8 @@ define Device/DniImage
        NETGEAR_HW_ID :=
        UBINIZE_OPTS := -E 5
        IMAGES := factory.img sysupgrade.bin
-       IMAGE/factory.img := append-kernel | pad-offset $$$$(BLOCKSIZE) 64 | append-uImage-fakeroot-hdr | pad-to $$$$(KERNEL_SIZE) | append-ubi | netgear-dni
-       IMAGE/sysupgrade.bin := append-kernel | pad-offset $$$$(BLOCKSIZE) 64 | append-uImage-fakeroot-hdr | sysupgrade-tar kernel=$$$$@ | append-metadata
+       IMAGE/factory.img := append-kernel | pad-offset $$$$(BLOCKSIZE) 64 | append-uImage-fakehdr filesystem | pad-to $$$$(KERNEL_SIZE) | append-ubi | netgear-dni
+       IMAGE/sysupgrade.bin := append-kernel | pad-offset $$$$(BLOCKSIZE) 64 | append-uImage-fakehdr filesystem | sysupgrade-tar kernel=$$$$@ | append-metadata
 endef
 DEVICE_VARS += NETGEAR_BOARD_ID NETGEAR_HW_ID
 
@@ -73,20 +73,16 @@ define Device/ZyXELImage
        IMAGE/mmcblk0p4-kernel.bin := append-kernel
 endef
 
-define Device/avm_fritzbox-4040
-       $(call Device/FitImageLzma)
-       DEVICE_DTS := qcom-ipq4019-fritz4040
-       KERNEL_LOADADDR := 0x80208000
-       BLOCKSIZE := 4k
-       PAGESIZE := 256
-       BOARD_NAME := fritz4040
-       DEVICE_TITLE := AVM Fritz!Box 4040
-       IMAGE_SIZE := 29753344
-       IMAGES = sysupgrade.bin
-       IMAGE/sysupgrade.bin := append-kernel | append-rootfs | pad-rootfs | append-metadata
-       DEVICE_PACKAGES := kmod-usb-phy-qcom-ipq4019 ipq-wifi-fritz4040 fritz-tffs fritz-caldata u-boot-fritz4040
+define Device/compex_wpq864
+       $(call Device/FitImage)
+       $(call Device/UbiFit)
+       BLOCKSIZE := 128k
+       PAGESIZE := 2048
+       DEVICE_DTS := qcom-ipq8064-wpq864
+       DEVICE_TITLE := Compex WPQ864
+       DEVICE_PACKAGES := kmod-gpio-beeper
 endef
-TARGET_DEVICES += avm_fritzbox-4040
+TARGET_DEVICES += compex_wpq864
 
 define Device/linksys_ea8500
        $(call Device/LegacyImage)
@@ -94,7 +90,7 @@ define Device/linksys_ea8500
        PAGESIZE := 2048
        BLOCKSIZE := 128k
        KERNEL_SIZE := 3072k
-       KERNEL = kernel-bin | append-dtb | uImage none | append-uImage-fakeroot-hdr
+       KERNEL = kernel-bin | append-dtb | uImage none | append-uImage-fakehdr filesystem
        BOARD_NAME := ea8500
        SUPPORTED_DEVICES += ea8500
        UBINIZE_OPTS := -E 5
@@ -108,7 +104,7 @@ TARGET_DEVICES += linksys_ea8500
 define Device/netgear_d7800
        $(call Device/DniImage)
        DEVICE_DTS := qcom-ipq8064-d7800
-       KERNEL_SIZE := 2097152
+       KERNEL_SIZE := 4194304
        NETGEAR_BOARD_ID := D7800
        NETGEAR_HW_ID := 29764958+0+128+512+4x4+4x4
        BLOCKSIZE := 128k
@@ -123,7 +119,7 @@ TARGET_DEVICES += netgear_d7800
 define Device/netgear_r7500
        $(call Device/DniImage)
        DEVICE_DTS := qcom-ipq8064-r7500
-       KERNEL_SIZE := 2097152
+       KERNEL_SIZE := 4194304
        NETGEAR_BOARD_ID := R7500
        NETGEAR_HW_ID := 29764841+0+128+256+3x3+4x4
        BLOCKSIZE := 128k
@@ -138,7 +134,7 @@ TARGET_DEVICES += netgear_r7500
 define Device/netgear_r7500v2
        $(call Device/DniImage)
        DEVICE_DTS := qcom-ipq8064-r7500v2
-       KERNEL_SIZE := 2097152
+       KERNEL_SIZE := 4194304
        NETGEAR_BOARD_ID := R7500v2
        NETGEAR_HW_ID := 29764958+0+128+512+3x3+4x4
        BLOCKSIZE := 128k
@@ -153,7 +149,7 @@ TARGET_DEVICES += netgear_r7500v2
 define Device/netgear_r7800
        $(call Device/DniImage)
        DEVICE_DTS := qcom-ipq8065-r7800
-       KERNEL_SIZE := 2097152
+       KERNEL_SIZE := 4194304
        NETGEAR_BOARD_ID := R7800
        NETGEAR_HW_ID := 29764958+0+128+512+4x4+4x4+cascade
        BLOCKSIZE := 128k
@@ -165,51 +161,6 @@ define Device/netgear_r7800
 endef
 TARGET_DEVICES += netgear_r7800
 
-define Device/openmesh_a42
-       $(call Device/FitImageLzma)
-       DEVICE_DTS := qcom-ipq4019-a42
-       KERNEL_LOADADDR := 0x80208000
-       BLOCKSIZE := 64k
-       SUPPORTED_DEVICES := openmesh,a42
-       DEVICE_TITLE := OpenMesh A42
-       KERNEL = kernel-bin | lzma | fit lzma $$(DTS_DIR)/$$(DEVICE_DTS).dtb | pad-to $$(BLOCKSIZE)
-       IMAGE_SIZE := 15616k
-       IMAGES = factory.bin sysupgrade.bin
-       IMAGE/factory.bin := append-rootfs | pad-rootfs | openmesh-image ce_type=A42
-       IMAGE/sysupgrade.bin/squashfs := append-rootfs | pad-rootfs | sysupgrade-tar rootfs=$$$$@ | append-metadata
-       DEVICE_PACKAGES := ath10k-firmware-qca4019 uboot-envtools ipq-wifi-openmesh_a42
-endef
-TARGET_DEVICES += openmesh_a42
-
-define Device/qcom_ap-dk01.1-c1
-       DEVICE_TITLE := QCA AP-DK01.1-C1
-       BOARD_NAME := ap-dk01.1-c1
-       DEVICE_DTS := qcom-ipq4019-ap.dk01.1-c1
-       KERNEL_LOADADDR := 0x80208000
-       KERNEL_INSTALL := 1
-       KERNEL_SIZE := 4096k
-       IMAGE_SIZE := 26624k
-       $(call Device/FitImage)
-       IMAGES := sysupgrade.bin
-       IMAGE/sysupgrade.bin := append-kernel | pad-to $$$${KERNEL_SIZE} | append-rootfs | pad-rootfs | append-metadata
-       DEVICE_PACKAGES := ath10k-firmware-qca4019
-endef
-TARGET_DEVICES += qcom_ap-dk01.1-c1
-
-define Device/qcom_ap-dk04.1-c1
-       $(call Device/FitImage)
-       $(call Device/UbiFit)
-       DEVICE_DTS := qcom-ipq4019-ap.dk04.1-c1
-       KERNEL_LOADADDR := 0x80208000
-       KERNEL_INSTALL := 1
-       KERNEL_SIZE := 4048k
-       BLOCKSIZE := 128k
-       PAGESIZE := 2048
-       BOARD_NAME := ap-dk04.1-c1
-       DEVICE_TITLE := QCA AP-DK04.1-C1
-endef
-TARGET_DEVICES += qcom_ap-dk04.1-c1
-
 define Device/qcom_ipq8064-ap148
        $(call Device/FitImage)
        $(call Device/UbiFit)
@@ -264,7 +215,7 @@ define Device/tplink_vr2600v
        KERNEL_SUFFIX := -uImage
        KERNEL = kernel-bin | append-dtb | uImage none
        KERNEL_NAME := zImage
-       KERNEL_SIZE := 2097152
+       KERNEL_SIZE := 3145728
        DEVICE_DTS := qcom-ipq8064-vr2600v
        BLOCKSIZE := 128k
        PAGESIZE := 2048