ipq806x: replace caf nss-gmac driver by upstream stmmac
[openwrt/openwrt.git] / target / linux / ipq806x / patches-4.0 / 022-add-db149-dts.patch
index 9a036fb4515f16c39c249f19654a7c632e68aefe..29631b2c281a8b20e252ae7abd88040a47317fbc 100644 (file)
@@ -1,4 +1,4 @@
-From a32d6e7c8fca6371a2614924b89981bc912b6378 Mon Sep 17 00:00:00 2001
+From f26cc3733bdd697bd81ae505fc133fa7c9b6ea19 Mon Sep 17 00:00:00 2001
 From: Mathieu Olivari <mathieu@codeaurora.org>
 Date: Tue, 7 Apr 2015 19:58:58 -0700
 Subject: [PATCH] ARM: dts: qcom: add initial DB149 device-tree
@@ -9,15 +9,13 @@ SATA, USB2, USB3 and NOR flash.
 Signed-off-by: Mathieu Olivari <mathieu@codeaurora.org>
 ---
  arch/arm/boot/dts/Makefile               |   1 +
- arch/arm/boot/dts/qcom-ipq8064-db149.dts | 257 +++++++++++++++++++++++++++++++
- 2 files changed, 258 insertions(+)
+ arch/arm/boot/dts/qcom-ipq8064-db149.dts | 132 +++++++++++++++++++++++++++++++
+ 2 files changed, 133 insertions(+)
  create mode 100644 arch/arm/boot/dts/qcom-ipq8064-db149.dts
 
-diff --git a/arch/arm/boot/dts/Makefile b/arch/arm/boot/dts/Makefile
-index 38c89ca..745360a 100644
 --- a/arch/arm/boot/dts/Makefile
 +++ b/arch/arm/boot/dts/Makefile
-@@ -360,6 +360,7 @@ dtb-$(CONFIG_ARCH_QCOM) += \
+@@ -438,6 +438,7 @@ dtb-$(CONFIG_ARCH_QCOM) += \
        qcom-apq8084-ifc6540.dtb \
        qcom-apq8084-mtp.dtb \
        qcom-ipq8064-ap148.dtb \
@@ -25,12 +23,9 @@ index 38c89ca..745360a 100644
        qcom-msm8660-surf.dtb \
        qcom-msm8960-cdp.dtb \
        qcom-msm8974-sony-xperia-honami.dtb
-diff --git a/arch/arm/boot/dts/qcom-ipq8064-db149.dts b/arch/arm/boot/dts/qcom-ipq8064-db149.dts
-new file mode 100644
-index 0000000..224c54f
 --- /dev/null
 +++ b/arch/arm/boot/dts/qcom-ipq8064-db149.dts
-@@ -0,0 +1,257 @@
+@@ -0,0 +1,132 @@
 +#include "qcom-ipq8064-v1.0.dtsi"
 +
 +/ {
@@ -55,15 +50,8 @@ index 0000000..224c54f
 +              linux,stdout-path = "serial0:115200n8";
 +      };
 +
-+      aliases {
-+              mdio-gpio0 = &mdio0;
-+      };
-+
 +      soc {
 +              pinmux@800000 {
-+                      pinctrl-0 = <&mdio0_pins &rgmii0_pinmux>;
-+                      pinctrl-names = "default";
-+
 +                      i2c4_pins: i2c4_pinmux {
 +                              pins = "gpio12", "gpio13";
 +                              function = "gsbi4";
@@ -78,23 +66,6 @@ index 0000000..224c54f
 +                                      bias-none;
 +                              };
 +                      };
-+
-+                      mdio0_pins: mdio0_pins {
-+                              mux {
-+                                      pins = "gpio0", "gpio1";
-+                                      function = "gpio";
-+                                      drive-strength = <8>;
-+                                      bias-disable;
-+                              };
-+                      };
-+
-+                      rgmii0_pinmux: rgmii0_pinmux {
-+                              mux {
-+                                      pins = "gpio2", "gpio66";
-+                                      drive-strength = <8>;
-+                                      bias-disable;
-+                              };
-+                      };
 +              };
 +
 +              gsbi2: gsbi@12480000 {
@@ -185,109 +156,5 @@ index 0000000..224c54f
 +              usb30@1 {
 +                      status = "ok";
 +              };
-+
-+              mdio0: mdio {
-+                      compatible = "virtual,mdio-gpio";
-+                      #address-cells = <1>;
-+                      #size-cells = <0>;
-+                      gpios = <&qcom_pinmux 1 0 &qcom_pinmux 0 0>;
-+
-+                      phy0: ethernet-phy@0 {
-+                              device_type = "ethernet-phy";
-+                              reg = <0>;
-+                              qca,ar8327-initvals = <
-+                                      0x00004 0x7600000   /* PAD0_MODE */
-+                                      0x00008 0x1000000   /* PAD5_MODE */
-+                                      0x0000c 0x80        /* PAD6_MODE */
-+                                      0x000e4 0xaa545     /* MAC_POWER_SEL */
-+                                      0x000e0 0xc74164de  /* SGMII_CTRL */
-+                                      0x0007c 0x4e        /* PORT0_STATUS */
-+                                      0x00094 0x4e        /* PORT6_STATUS */
-+                              >;
-+                      };
-+
-+                      phy4: ethernet-phy@4 {
-+                              device_type = "ethernet-phy";
-+                              reg = <4>;
-+                      };
-+
-+                      phy6: ethernet-phy@6 {
-+                              device_type = "ethernet-phy";
-+                              reg = <6>;
-+                      };
-+
-+                      phy7: ethernet-phy@7 {
-+                              device_type = "ethernet-phy";
-+                              reg = <7>;
-+                      };
-+              };
-+
-+              nss-gmac-common {
-+                      reg = <0x03000000 0x0000FFFF 0x1bb00000 0x0000FFFF 0x00900000 0x00004000>;
-+                      reg-names = "nss_reg_base" , "qsgmii_reg_base", "clk_ctl_base";
-+              };
-+
-+              gmac0: ethernet@37000000 {
-+                      status = "ok";
-+                      phy-mode = "rgmii";
-+                      qcom,id = <0>;
-+                      qcom,phy_mdio_addr = <4>;
-+                      qcom,poll_required = <1>;
-+                      qcom,rgmii_delay = <1>;
-+                      qcom,emulation = <0>;
-+                      qcom,forced_speed = <1000>;
-+                      qcom,forced_duplex = <1>;
-+                      qcom,socver = <0>;
-+                      local-mac-address = [000000000000];
-+                      mdiobus = <&mdio0>;
-+              };
-+
-+              gmac1: ethernet@37200000 {
-+                      status = "ok";
-+                      phy-mode = "sgmii";
-+                      qcom,id = <1>;
-+                      qcom,phy_mdio_addr = <0>;
-+                      qcom,poll_required = <0>;
-+                      qcom,rgmii_delay = <0>;
-+                      qcom,emulation = <0>;
-+                      qcom,forced_speed = <1000>;
-+                      qcom,forced_duplex = <1>;
-+                      qcom,socver = <0>;
-+                      local-mac-address = [000000000000];
-+                      mdiobus = <&mdio0>;
-+              };
-+
-+              gmac2: ethernet@37400000 {
-+                      status = "ok";
-+                      phy-mode = "sgmii";
-+                      qcom,id = <2>;
-+                      qcom,phy_mdio_addr = <6>;
-+                      qcom,poll_required = <1>;
-+                      qcom,rgmii_delay = <0>;
-+                      qcom,emulation = <0>;
-+                      qcom,forced_speed = <0>;
-+                      qcom,forced_duplex = <0>;
-+                      qcom,socver = <0>;
-+                      local-mac-address = [000000000000];
-+                      mdiobus = <&mdio0>;
-+              };
-+
-+              gmac3: ethernet@37600000 {
-+                      status = "ok";
-+                      phy-mode = "sgmii";
-+                      qcom,id = <3>;
-+                      qcom,phy_mdio_addr = <7>;
-+                      qcom,poll_required = <1>;
-+                      qcom,rgmii_delay = <0>;
-+                      qcom,emulation = <0>;
-+                      qcom,forced_speed = <0>;
-+                      qcom,forced_duplex = <0>;
-+                      qcom,socver = <0>;
-+                      local-mac-address = [000000000000];
-+                      mdiobus = <&mdio0>;
-+              };
 +      };
 +};
--- 
-1.9.1
-