kernel: bump 4.14 to 4.14.48 for 18.06
[openwrt/openwrt.git] / target / linux / ipq806x / patches-4.14 / 0042-clk-qcom-Add-KPSS-ACC-GCC-driver.patch
index 8846dba1a3a55d38b43b857d07ab5955b7b9642a..93c86ebb6948521d8e3b8185859d7a81ca494023 100644 (file)
@@ -35,9 +35,9 @@ Signed-off-by: Stephen Boyd <sboyd@codeaurora.org>
 --- a/Documentation/devicetree/bindings/arm/msm/qcom,kpss-acc.txt
 +++ b/Documentation/devicetree/bindings/arm/msm/qcom,kpss-acc.txt
 @@ -21,10 +21,17 @@ PROPERTIES
-                   the register region. An optional second element specifies
-                   the base address and size of the alias register region.
-
+                   the register region. An optional second element specifies
+                   the base address and size of the alias register region.
 +- clock-output-names:
 +      Usage: optional
 +      Value type: <string>
@@ -45,13 +45,13 @@ Signed-off-by: Stephen Boyd <sboyd@codeaurora.org>
 +                  CPU number starting at 0.
 +
  Example:
-
-       clock-controller@2088000 {
-               compatible = "qcom,kpss-acc-v2";
-               reg = <0x02088000 0x1000>,
-                     <0x02008000 0x1000>;
+       clock-controller@2088000 {
+               compatible = "qcom,kpss-acc-v2";
+               reg = <0x02088000 0x1000>,
+                     <0x02008000 0x1000>;
 +              clock-output-names = "acpu0_aux";
-       };
+       };
 --- /dev/null
 +++ b/Documentation/devicetree/bindings/arm/msm/qcom,kpss-gcc.txt
 @@ -0,0 +1,28 @@
@@ -86,9 +86,9 @@ Signed-off-by: Stephen Boyd <sboyd@codeaurora.org>
 --- a/drivers/clk/qcom/Kconfig
 +++ b/drivers/clk/qcom/Kconfig
 @@ -205,6 +205,14 @@ config QCOM_HFPLL
-         Say Y if you want to support CPU frequency scaling on devices
-         such as MSM8974, APQ8084, etc.
-
+         Say Y if you want to support CPU frequency scaling on devices
+         such as MSM8974, APQ8084, etc.
 +config KPSS_XCC
 +      tristate "KPSS Clock Controller"
 +      depends on COMMON_CLK_QCOM
@@ -98,8 +98,8 @@ Signed-off-by: Stephen Boyd <sboyd@codeaurora.org>
 +        as MSM8960, APQ8064, etc.
 +
  config KRAIT_CLOCKS
-       bool
-       select KRAIT_L2_ACCESSORS
+       bool
+       select KRAIT_L2_ACCESSORS
 --- a/drivers/clk/qcom/Makefile
 +++ b/drivers/clk/qcom/Makefile
 @@ -36,4 +36,5 @@ obj-$(CONFIG_MSM_MMCC_8974) += mmcc-msm8