update config, make 2.6.26-rc8 the default for ixp4xx
[openwrt/openwrt.git] / target / linux / ixp4xx / Makefile
index 25b60a47b720fe3c96c4b7be6d6802b9d885ea27..1e2a52ff07ad6bbe0c34eadef6a150dee3b32ba3 100644 (file)
@@ -1,5 +1,5 @@
-# 
-# Copyright (C) 2006 OpenWrt.org
+#
+# Copyright (C) 2006-2008 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -8,17 +8,20 @@ include $(TOPDIR)/rules.mk
 
 ARCH:=armeb
 BOARD:=ixp4xx
-BOARDNAME:=Intel XScale IXP4xx
+BOARDNAME:=Intel IXP4xx
 FEATURES:=squashfs
+SUBTARGETS=generic harddisk
 
-LINUX_VERSION:=2.6.21.6
+LINUX_VERSION:=2.6.26-rc8
 
-define Target/Description
-endef
+include $(INCLUDE_DIR)/target.mk
 
-include $(INCLUDE_DIR)/kernel-build.mk
+define Kernel/Configure
+       $(call Kernel/Configure/Default)
+       $(SED) 's,.*CONFIG_AEABI.*,$(if $(CONFIG_EABI_SUPPORT),CONFIG_AEABI=y,# CONFIG_AEABI is not set),' $(LINUX_DIR)/.config
+       $(if $(CONFIG_EABI_SUPPORT),echo '# CONFIG_OABI_COMPAT is not set' >> $(LINUX_DIR)/.config)
+endef
 
-# include the profiles
--include profiles/*.mk
+DEFAULT_PACKAGES += ixp4xx-microcode fconfig
 
-$(eval $(call BuildKernel))
+$(eval $(call BuildTarget))