ixp4xx: replace magic number with macros in avila/ixdp425/miccpt PCI routing setup
[openwrt/openwrt.git] / target / linux / ixp4xx / Makefile
index fec02efc34891b6284296807a3e6b5d5e66cdd4f..1eb1abb287dc13db25bb68ba276b187f57385776 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2006-2008 OpenWrt.org
+# Copyright (C) 2006-2011 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -10,18 +10,14 @@ ARCH:=armeb
 BOARD:=ixp4xx
 BOARDNAME:=Intel IXP4xx
 FEATURES:=squashfs
+MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
 SUBTARGETS=generic harddisk
 
-LINUX_VERSION:=2.6.25.7
+LINUX_VERSION:=3.10
 
 include $(INCLUDE_DIR)/target.mk
 
-define Kernel/Configure
-       $(call Kernel/Configure/Default)
-       $(SED) 's,.*CONFIG_AEABI.*,$(if $(CONFIG_EABI_SUPPORT),CONFIG_AEABI=y,# CONFIG_AEABI is not set),' $(LINUX_DIR)/.config
-       $(if $(CONFIG_EABI_SUPPORT),echo '# CONFIG_OABI_COMPAT is not set' >> $(LINUX_DIR)/.config)
-endef
-
 DEFAULT_PACKAGES += ixp4xx-microcode fconfig
+KERNELNAME:="zImage"
 
 $(eval $(call BuildTarget))