brcm63xx: fix invalid Asmax AR 1004g DTS reference
[openwrt/openwrt.git] / target / linux / kirkwood / Makefile
index b14fb0eab0bd40d5a03ba5ced7617e86dccfb718..8c8c272f9807bcc22f545cf72fa3f82bb5c47df1 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2009 OpenWrt.org
+# Copyright (C) 2009-2015 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -9,14 +9,16 @@ include $(TOPDIR)/rules.mk
 ARCH:=arm
 BOARD:=kirkwood
 BOARDNAME:=Marvell Kirkwood
-FEATURES:=jffs2 usb broken
+FEATURES:=usb nand squashfs ramdisk
+CPU_TYPE:=xscale
+MAINTAINER:=Luka Perkov <luka@openwrt.org>
 
-LINUX_VERSION:=2.6.30-rc7
+KERNEL_PATCHVER:=4.4
 
 include $(INCLUDE_DIR)/target.mk
 
-KERNELNAME:="uImage"
+KERNELNAME:=zImage dtbs
 
-DEFAULT_PACKAGES +=
+DEFAULT_PACKAGES += uboot-envtools
 
 $(eval $(call BuildTarget))