kirkwood: sort occurrences of boardame alphabetically
[openwrt/openwrt.git] / target / linux / kirkwood / image / Makefile
index aceeb9b5764f00b087adf7c5bc2ee741adbeb9ce..39d93275f4a8507ab9f2b58a2afc6afb815f441e 100644 (file)
@@ -27,29 +27,40 @@ define Device/Default
   SUPPORTED_DEVICES := $(subst _,$(comma),$(1))
 endef
 
-define Device/seagate_dockstar
-  DEVICE_DTS := kirkwood-dockstar
-  DEVICE_TITLE := Seagate FreeAgent Dockstar
-  BOARD_NAME := dockstar
-  SUPPORTED_DEVICES += dockstar
+define Device/cisco_on100
+  DEVICE_TITLE := Cisco Systems ON100
+  DEVICE_DTS := kirkwood-on100
+  DEVICE_PACKAGES := kmod-i2c-mv64xxx
+  KERNEL_SIZE := 5376k
+  KERNEL_IN_UBI := 0
+  UBINIZE_OPTS := -E 5
+  IMAGE/factory.bin := append-kernel | pad-to $$$$(KERNEL_SIZE) | append-ubi
+  BOARD_NAME := on100
 endef
-TARGET_DEVICES += seagate_dockstar
+TARGET_DEVICES += cisco_on100
 
-define Device/seagate_goflexnet
-  DEVICE_TITLE := Seagate GoFlexNet
-  DEVICE_DTS := kirkwood-goflexnet
-  BOARD_NAME := goflexnet
-  SUPPORTED_DEVICES += goflexnet
+define Device/cloudengines_pogoe02
+  DEVICE_TITLE := Cloud Engines Pogoplug E02
+  DEVICE_DTS := kirkwood-pogo_e02
+  BOARD_NAME := pogo_e02
+  SUPPORTED_DEVICES += pogo_e02
 endef
-TARGET_DEVICES += seagate_goflexnet
+TARGET_DEVICES += cloudengines_pogoe02
 
-define Device/seagate_goflexhome
-  DEVICE_TITLE := Seagate GoFlexHome
-  DEVICE_DTS := kirkwood-goflexhome
-  BOARD_NAME := goflexhome
-  SUPPORTED_DEVICES += goflexhome
+define Device/cloudengines_pogoplugv4
+  DEVICE_TITLE := Cloud Engines Pogoplug V4
+  DEVICE_DTS := kirkwood-pogoplug-series-4
+  DEVICE_PACKAGES := kmod-usb3
 endef
-TARGET_DEVICES += seagate_goflexhome
+TARGET_DEVICES += cloudengines_pogoplugv4
+
+define Device/iom_iconnect-1.1
+  DEVICE_TITLE := Iomega Iconnect
+  DEVICE_DTS := kirkwood-iconnect
+  BOARD_NAME := iconnect
+  SUPPORTED_DEVICES += iconnect
+endef
+TARGET_DEVICES += iom_iconnect-1.1
 
 define Device/linksys_audi
   DEVICE_TITLE := Linksys EA3500 (Audi)
@@ -77,13 +88,37 @@ define Device/linksys_viper
 endef
 TARGET_DEVICES += linksys_viper
 
-define Device/iom_iconnect-1.1
-  DEVICE_TITLE := Iomega Iconnect
-  DEVICE_DTS := kirkwood-iconnect
-  BOARD_NAME := iconnect
-  SUPPORTED_DEVICES += iconnect
+define Device/raidsonic_ib-nas62x0
+  DEVICE_TITLE := RaidSonic ICY BOX IB-NAS62x0
+  DEVICE_DTS := kirkwood-ib62x0
+  BOARD_NAME := ib62x0
+  SUPPORTED_DEVICES += ib62x0
 endef
-TARGET_DEVICES += iom_iconnect-1.1
+TARGET_DEVICES += raidsonic_ib-nas62x0
+
+define Device/seagate_dockstar
+  DEVICE_DTS := kirkwood-dockstar
+  DEVICE_TITLE := Seagate FreeAgent Dockstar
+  BOARD_NAME := dockstar
+  SUPPORTED_DEVICES += dockstar
+endef
+TARGET_DEVICES += seagate_dockstar
+
+define Device/seagate_goflexnet
+  DEVICE_TITLE := Seagate GoFlexNet
+  DEVICE_DTS := kirkwood-goflexnet
+  BOARD_NAME := goflexnet
+  SUPPORTED_DEVICES += goflexnet
+endef
+TARGET_DEVICES += seagate_goflexnet
+
+define Device/seagate_goflexhome
+  DEVICE_TITLE := Seagate GoFlexHome
+  DEVICE_DTS := kirkwood-goflexhome
+  BOARD_NAME := goflexhome
+  SUPPORTED_DEVICES += goflexhome
+endef
+TARGET_DEVICES += seagate_goflexhome
 
 define Device/zyxel_nsa310b
   DEVICE_TITLE := ZyXEL NSA310b
@@ -101,32 +136,4 @@ define Device/zyxel_nsa325
 endef
 TARGET_DEVICES += zyxel_nsa325
 
-define Device/cisco_on100
-  DEVICE_TITLE := Cisco Systems ON100
-  DEVICE_DTS := kirkwood-on100
-  DEVICE_PACKAGES := kmod-i2c-mv64xxx
-  KERNEL_SIZE := 5376k
-  KERNEL_IN_UBI := 0
-  UBINIZE_OPTS := -E 5
-  IMAGE/factory.bin := append-kernel | pad-to $$$$(KERNEL_SIZE) | append-ubi
-  BOARD_NAME := on100
-endef
-TARGET_DEVICES += cisco_on100
-
-define Device/cloudengines_pogoe02
-  DEVICE_TITLE := Cloud Engines Pogoplug E02
-  DEVICE_DTS := kirkwood-pogo_e02
-  BOARD_NAME := pogo_e02
-  SUPPORTED_DEVICES += pogo_e02
-endef
-TARGET_DEVICES += cloudengines_pogoe02
-
-define Device/raidsonic_ib-nas62x0
-  DEVICE_TITLE := RaidSonic ICY BOX IB-NAS62x0
-  DEVICE_DTS := kirkwood-ib62x0
-  BOARD_NAME := ib62x0
-  SUPPORTED_DEVICES += ib62x0
-endef
-TARGET_DEVICES += raidsonic_ib-nas62x0
-
 $(eval $(call BuildImage))