kirkwood: add ZyXEL NSA310b
[openwrt/openwrt.git] / target / linux / kirkwood / image / Makefile
index 520430f2c23818009e3ccc80ee78f044aff3cd37..ece7c1adf6ec67280743b7082b4a991f82e27a77 100644 (file)
@@ -11,7 +11,7 @@ include $(TOPDIR)/rules.mk
 include $(INCLUDE_DIR)/image.mk
 
 KERNEL_LOADADDR:=0x8000
-TARGET_DEVICES = linksys-audi linksys-viper dockstar goflexnet goflexhome iconnect pogo_e02 ib62x0
+TARGET_DEVICES = linksys-audi linksys-viper dockstar goflexnet goflexhome iconnect pogo_e02 ib62x0 nsa310b
 
 UBI_OPTS := -m 2048 -p 128KiB -s 512
 UBIFS_OPTS := -m 2048 -e 126KiB -c 4096
@@ -80,6 +80,13 @@ $(Device/dockstar)
   DEVICE_DTS := kirkwood-iconnect
 endef
 
+define Device/nsa310b
+$(Device/dockstar)
+  DEVICE_TITLE := ZyXEL NSA310b
+  DEVICE_DTS := kirkwood-nsa310b
+  DEVICE_PACKAGES := kmod-r8169 kmod-gpio-button-hotplug kmod-hwmon-lm85
+endef
+
 define Device/pogo_e02
 $(Device/dockstar)
   DEVICE_TITLE := Cloud Engines Pogoplug E02