kirkwood: enable swconfig by default on EA3500
[openwrt/openwrt.git] / target / linux / kirkwood / profiles / 115-router.mk
index ef7f228d2c4d8d80cff4b61e06899f8114826c4a..769284f7ea35a41ae6c7e9bfee293a57185842e0 100644 (file)
@@ -9,15 +9,15 @@ define Profile/EA3500
   NAME:=Linksys EA3500
   PACKAGES:= \
        kmod-mwl8k kmod-usb2 kmod-usb-storage \
-       uboot-envtools
+       swconfig uboot-envtools
 endef
 
 define Profile/EA3500/Description
  Package set compatible with Linksys EA3500 board.
 endef
 
-EA3500_UBIFS_OPTS:="-m 2048 -e 126KiB -c 4096"
-EA3500_UBI_OPTS:="-m 2048 -p 128KiB -s 512"
+EA3500_UBIFS_OPTS:="-m 512 -e 15872 -c 4096"
+EA3500_UBI_OPTS:="-m 512 -p 16384 -s 256"
 
 $(eval $(call Profile,EA3500))
 
@@ -25,7 +25,7 @@ define Profile/EA4500
   NAME:=Linksys EA4500
   PACKAGES:= \
        kmod-mwl8k kmod-usb2 kmod-usb-storage \
-       uboot-envtools
+       swconfig uboot-envtools
 endef
 
 define Profile/EA4500/Description