lantiq: add Linux 5.10 support as testing kernel
[openwrt/openwrt.git] / target / linux / lantiq / Makefile
index c8e376ccf494d9ee6ebb9cbcc12237b1cf249651..611a09256fcdda18fa496f0da37e95d015db7e73 100644 (file)
@@ -1,21 +1,16 @@
+# SPDX-License-Identifier: GPL-2.0-only
 #
 # Copyright (C) 2007-2011 OpenWrt.org
-#
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-#
+
 include $(TOPDIR)/rules.mk
 
 BOARD:=lantiq
-BOARDNAME:=Lantiq GPON/XWAY/SVIP
-FEATURES:=squashfs jffs2
-SUBTARGETS:=danube ar9 vr9 falcon svip_be
-LINUX_VERSION:=3.3.8
-
-#SUBTARGETS=xway ase
-#LINUX_VERSION:=3.6.5
+BOARDNAME:=Lantiq
+FEATURES:=squashfs
+SUBTARGETS:=xrx200 xway xway_legacy falcon ase
 
-CFLAGS=-Os -pipe -mips32r2 -mtune=mips32r2 -fno-caller-saves
+KERNEL_PATCHVER:=5.4
+KERNEL_TESTING_PATCHVER:=5.10
 
 define Target/Description
        Build firmware images for Lantiq SoC