lantiq: several a803 related fixes
[openwrt/openwrt.git] / target / linux / lantiq / Makefile
index b0bed09dfd099d750ae704e7362ce911378842a0..94b506d4eec539e5bde5949fd50d9c5826df9fb1 100644 (file)
@@ -6,15 +6,14 @@
 #
 include $(TOPDIR)/rules.mk
 
-ARCH:=mips
 BOARD:=lantiq
-BOARDNAME:=Lantiq GPON/XWAY
-FEATURES:=squashfs jffs2
-DEFAULT_SUBTARGET:=danube
+BOARDNAME:=Lantiq GPON/XWAY/SVIP
+FEATURES:=squashfs
+SUBTARGETS=xway ase falcon
 
-LINUX_VERSION:=3.1.10
+LINUX_VERSION:=3.8.13
 
-CFLAGS=-Os -pipe -mips32r2 -mtune=mips32r2 -fno-caller-saves
+CFLAGS=-Os -pipe -mips32r2 -mno-branch-likely
 
 define Target/Description
        Build firmware images for Lantiq SoC