kernel: update 3.10 to 3.10.32
[openwrt/openwrt.git] / target / linux / lantiq / Makefile
index 14c24813c6b6db90828ed37baf1be7d3f703067e..a67923cbb8c6da6ad195ea4b2e91e445bd1d554c 100644 (file)
@@ -1,25 +1,24 @@
 #
-# Copyright (C) 2007-2010 OpenWrt.org
+# Copyright (C) 2007-2011 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
 include $(TOPDIR)/rules.mk
 
-ARCH:=mips
 BOARD:=lantiq
-BOARDNAME:=Lantiq GPON/XWAY
-FEATURES:=squashfs jffs2
-SUBTARGETS:=falcon xway
+BOARDNAME:=Lantiq GPON/XWAY/SVIP
+FEATURES:=squashfs
+SUBTARGETS=xway xrx200 ase falcon
 
-LINUX_VERSION:=2.6.37.3
+LINUX_VERSION:=3.10.32
 
-CFLAGS=-Os -pipe -mips32r2 -mtune=mips32r2 -funit-at-a-time
-
-include $(INCLUDE_DIR)/target.mk
+CPU_TYPE:=mips32r2
 
 define Target/Description
        Build firmware images for Lantiq SoC
 endef
 
+include $(INCLUDE_DIR)/target.mk
+
 $(eval $(call BuildTarget))