add linux-v3.7
[openwrt/openwrt.git] / target / linux / lantiq / Makefile
index b040e3fd38d1d9b6531f3131f77ae96dc20cc0d3..a8e61709ba45d566541e83641383673b241a196e 100644 (file)
@@ -6,20 +6,21 @@
 #
 include $(TOPDIR)/rules.mk
 
-ARCH:=mips
 BOARD:=lantiq
-BOARDNAME:=Lantiq GPON/XWAY
+BOARDNAME:=Lantiq GPON/XWAY/SVIP
 FEATURES:=squashfs jffs2
-SUBTARGETS:=xway falcon ase
+SUBTARGETS:=danube ar9 vr9 falcon svip_be
+LINUX_VERSION:=3.3.8
 
-LINUX_VERSION:=2.6.39.1
+SUBTARGETS=xway ase falcon
+LINUX_VERSION:=3.7-rc8
 
 CFLAGS=-Os -pipe -mips32r2 -mtune=mips32r2 -fno-caller-saves
 
-include $(INCLUDE_DIR)/target.mk
-
 define Target/Description
        Build firmware images for Lantiq SoC
 endef
 
+include $(INCLUDE_DIR)/target.mk
+
 $(eval $(call BuildTarget))