lantiq: Add support for linux 4.4
[openwrt/openwrt.git] / target / linux / lantiq / Makefile
index c09be31a6eee0604741a5b927c856ad360335a07..d19be828abbfc56e9cdfecf36bdcb9f10116cced 100644 (file)
@@ -6,15 +6,15 @@
 #
 include $(TOPDIR)/rules.mk
 
-ARCH:=mips
 BOARD:=lantiq
-BOARDNAME:=Lantiq GPON/XWAY
-FEATURES:=squashfs jffs2
-SUBTARGETS:=xway falcon ase
+BOARDNAME:=Lantiq
+FEATURES:=squashfs
+SUBTARGETS=xway xrx200
+MAINTAINER:=John Crispin <blogic@openwrt.org>
 
-LINUX_VERSION:=2.6.39.2
+KERNEL_PATCHVER:=4.1
 
-CFLAGS=-Os -pipe -mips32r2 -mtune=mips32r2 -fno-caller-saves
+CPU_TYPE:=mips32r2
 
 define Target/Description
        Build firmware images for Lantiq SoC