lantiq: set 3.14 as default
[openwrt/openwrt.git] / target / linux / lantiq / Makefile
index b040e3fd38d1d9b6531f3131f77ae96dc20cc0d3..f5ba6bf4f498cd9df2a7c6a49b857c58792cb37b 100644 (file)
@@ -6,20 +6,20 @@
 #
 include $(TOPDIR)/rules.mk
 
 #
 include $(TOPDIR)/rules.mk
 
-ARCH:=mips
 BOARD:=lantiq
 BOARD:=lantiq
-BOARDNAME:=Lantiq GPON/XWAY
-FEATURES:=squashfs jffs2
-SUBTARGETS:=xway falcon ase
+BOARDNAME:=Lantiq
+FEATURES:=squashfs
+SUBTARGETS=xway xrx200
+MAINTAINER:=John Crispin <blogic@openwrt.org>
 
 
-LINUX_VERSION:=2.6.39.1
+LINUX_VERSION:=3.14.18
 
 
-CFLAGS=-Os -pipe -mips32r2 -mtune=mips32r2 -fno-caller-saves
-
-include $(INCLUDE_DIR)/target.mk
+CPU_TYPE:=mips32r2
 
 define Target/Description
        Build firmware images for Lantiq SoC
 endef
 
 
 define Target/Description
        Build firmware images for Lantiq SoC
 endef
 
+include $(INCLUDE_DIR)/target.mk
+
 $(eval $(call BuildTarget))
 $(eval $(call BuildTarget))