kernel: disable CONFIG_PCIE_BUS_PERFORMANCE
[openwrt/openwrt.git] / target / linux / lantiq / modules.mk
index a4a96400d0daa32e5225334cb1d4abd7825e4367..14140b1095d3d80a19bb46e52805090be7bf49ec 100644 (file)
@@ -1,62 +1,19 @@
+# SPDX-License-Identifier: GPL-2.0-only
 #
 # Copyright (C) 2010 OpenWrt.org
-#
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-#
-
-define KernelPackage/lantiq-deu
-  TITLE:=Lantiq data encryption unit
-  SUBMENU:=$(CRYPTO_MENU)
-  DEPENDS:=@TARGET_lantiq
-  KCONFIG:=CONFIG_CRYPTO_DEV_LANTIQ \
-          CONFIG_CRYPTO_HW=y \
-          CONFIG_CRYPTO_DEV_LANTIQ_AES=y \
-          CONFIG_CRYPTO_DEV_LANTIQ_DES=y \
-          CONFIG_CRYPTO_DEV_LANTIQ_MD5=y \
-          CONFIG_CRYPTO_DEV_LANTIQ_SHA1=y
-  $(call AddDepends/crypto)
-endef
-
-define KernelPackage/lantiq-deu/description
-  Kernel support for the Lantiq crypto HW
-endef
-
-$(eval $(call KernelPackage,lantiq-deu))
-
-USB_MENU:=USB Support
-
-define KernelPackage/usb-dwc-otg
-  TITLE:=Synopsis DWC_OTG support
-  SUBMENU:=$(USB_MENU)
-  DEPENDS+=@TARGET_lantiq_xway +kmod-usb-core
-  KCONFIG:=CONFIG_DWC_OTG \
-       CONFIG_DWC_OTG_DEBUG=n \
-       CONFIG_DWC_OTG_LANTIQ=y \
-       CONFIG_DWC_OTG_HOST_ONLY=y \
-       CONFIG_DWC_OTG_DEVICE_ONLY=n
-  FILES:=$(LINUX_DIR)/drivers/usb/dwc_otg/dwc_otg.ko
-  AUTOLOAD:=$(call AutoLoad,50,dwc_otg)
-endef
-
-define KernelPackage/usb-dwc-otg/description
-  Kernel support for Synopsis USB on XWAY
-endef
-
-$(eval $(call KernelPackage,usb-dwc-otg))
 
-I2C_FALCON_MODULES:= \
-  CONFIG_I2C_FALCON:drivers/i2c/busses/i2c-falcon
+I2C_LANTIQ_MODULES:= \
+  CONFIG_I2C_LANTIQ:drivers/i2c/busses/i2c-lantiq
 
-define KernelPackage/i2c-falcon-lantiq
-  TITLE:=Falcon I2C controller
-  $(call i2c_defaults,$(I2C_FALCON_MODULES),52)
-  DEPENDS:=kmod-i2c-core @TARGET_lantiq
+define KernelPackage/i2c-lantiq
+  TITLE:=Lantiq I2C controller
+  $(call i2c_defaults,$(I2C_LANTIQ_MODULES),52)
+  DEPENDS:=+kmod-i2c-core @TARGET_lantiq_falcon
 endef
 
-define KernelPackage/i2c-falcon-lantiq/description
-  Kernel support for the Falcon I2C controller
+define KernelPackage/i2c-lantiq/description
+  Kernel support for the Lantiq/Falcon I2C controller
 endef
 
-$(eval $(call KernelPackage,i2c-falcon-lantiq))
+$(eval $(call KernelPackage,i2c-lantiq))