lantiq: build fullimage.img for EASY80920NAND
[openwrt/openwrt.git] / target / linux / lantiq / modules.mk
index 78289a1a11fa54746470125f3f4dfa0436f8af64..e7fbad3a29590f924c8349c34125bb73ddbf96c5 100644 (file)
@@ -5,43 +5,18 @@
 # See /LICENSE for more information.
 #
 
-define KernelPackage/lantiq-deu
-  TITLE:=Lantiq data encryption unit
-  SUBMENU:=$(CRYPTO_MENU)
-  DEPENDS:=@TARGET_lantiq
-  KCONFIG:=CONFIG_CRYPTO_DEV_LANTIQ \
-          CONFIG_CRYPTO_HW=y \
-          CONFIG_CRYPTO_DEV_LANTIQ_AES=y \
-          CONFIG_CRYPTO_DEV_LANTIQ_DES=y \
-          CONFIG_CRYPTO_DEV_LANTIQ_MD5=y \
-          CONFIG_CRYPTO_DEV_LANTIQ_SHA1=y
-  $(call AddDepends/crypto)
-endef
-
-define KernelPackage/lantiq-deu/description
-  Kernel support for the Lantiq crypto HW
-endef
+I2C_LANTIQ_MODULES:= \
+  CONFIG_I2C_LANTIQ:drivers/i2c/busses/i2c-lantiq
 
-$(eval $(call KernelPackage,lantiq-deu))
-
-USB_MENU:=USB Support
-
-define KernelPackage/usb-dwc-otg
-  TITLE:=Synopsis DWC_OTG support
-  SUBMENU:=$(USB_MENU)
-  DEPENDS+=@TARGET_lantiq_xway +kmod-usb-core
-  KCONFIG:=CONFIG_DWC_OTG \
-       CONFIG_DWC_OTG_DEBUG=n \
-       CONFIG_DWC_OTG_LANTIQ=y \
-       CONFIG_DWC_OTG_HOST_ONLY=y
-  FILES:=$(LINUX_DIR)/drivers/usb/dwc_otg/dwc_otg.ko
-  AUTOLOAD:=$(call AutoLoad,50,dwc_otg)
+define KernelPackage/i2c-lantiq
+  TITLE:=Lantiq I2C controller
+  $(call i2c_defaults,$(I2C_LANTIQ_MODULES),52)
+  DEPENDS:=kmod-i2c-core @TARGET_lantiq_falcon
 endef
 
-define KernelPackage/usb-dwc-otg/description
-  Kernel support for Synopsis USB on XWAY
+define KernelPackage/i2c-lantiq/description
+  Kernel support for the Lantiq/Falcon I2C controller
 endef
 
-$(eval $(call KernelPackage,usb-dwc-otg))
-
+$(eval $(call KernelPackage,i2c-lantiq))