mpc85xx: remove linux 3.10 support
[openwrt/openwrt.git] / target / linux / lantiq / patches-3.10 / 0007-MIPS-lantiq-handle-vmmc-memory-reservation.patch
index 50076bc5b6ee5ef87415dcaf71539025b3867ad8..d1b1e08a4720d2b28cf442cd261b85b894484571 100644 (file)
@@ -10,8 +10,6 @@ Signed-off-by: John Crispin <blogic@openwrt.org>
  2 files changed, 65 insertions(+)
  create mode 100644 arch/mips/lantiq/xway/vmmc.c
 
-diff --git a/arch/mips/lantiq/xway/Makefile b/arch/mips/lantiq/xway/Makefile
-index 087497d..a2edc53 100644
 --- a/arch/mips/lantiq/xway/Makefile
 +++ b/arch/mips/lantiq/xway/Makefile
 @@ -1,3 +1,5 @@
@@ -20,9 +18,6 @@ index 087497d..a2edc53 100644
 +obj-y += vmmc.o
 +
  obj-$(CONFIG_XRX200_PHY_FW) += xrx200_phy_fw.o
-diff --git a/arch/mips/lantiq/xway/vmmc.c b/arch/mips/lantiq/xway/vmmc.c
-new file mode 100644
-index 0000000..6dedf77
 --- /dev/null
 +++ b/arch/mips/lantiq/xway/vmmc.c
 @@ -0,0 +1,63 @@
@@ -59,7 +54,7 @@ index 0000000..6dedf77
 +              (void*)CPHYSADDR(dma_alloc_coherent(NULL, CP1_SIZE, &dma, GFP_ATOMIC));
 +
 +      gpio_count = of_gpio_count(pdev->dev.of_node);
-+      while (gpio_count) {
++      while (gpio_count > 0) {
 +              enum of_gpio_flags flags;
 +              int gpio = of_get_gpio_flags(pdev->dev.of_node, --gpio_count, &flags);
 +              if (gpio_request(gpio, "vmmc-relay"))
@@ -89,6 +84,3 @@ index 0000000..6dedf77
 +};
 +
 +module_platform_driver(vmmc_driver);
--- 
-1.7.10.4
-