layerscape: add linux 4.9 support
[openwrt/openwrt.git] / target / linux / layerscape / Makefile
index 3def184b948bde18b7d5b6533797e9cc8b8d8d51..67da8449aac230aa0bf925b9093dc9902515b4e3 100644 (file)
@@ -9,18 +9,17 @@ include $(TOPDIR)/rules.mk
 BOARD:=layerscape
 BOARDNAME:=NXP Layerscape
 DEVICE_TYPE:=developerboard
-KERNEL_PATCHVER:=4.4
-KERNELNAME:=Image dtbs
+KERNEL_PATCHVER:=4.9
 FEATURES:=squashfs nand usb pcie gpio
-SUBTARGETS:=64b 32b
+SUBTARGETS:=armv8_64b armv8_32b
 MAINTAINER:=Yangbo Lu <yangbo.lu@nxp.com>
 
-include $(INCLUDE_DIR)/target.mk
-
 define Target/Description
-       Build firmware images for $(BOARDNAME) SoC devices.
+       Build firmware images for NXP Layerscape based boards.
 endef
 
+include $(INCLUDE_DIR)/target.mk
+
 DEFAULT_PACKAGES += kmod-usb3 kmod-usb-dwc3 kmod-usb-storage
 
 $(eval $(call BuildTarget))