kernel: disable CONFIG_PCIE_BUS_PERFORMANCE
[openwrt/openwrt.git] / target / linux / layerscape / Makefile
index 3def184b948bde18b7d5b6533797e9cc8b8d8d51..71034224ab944c8bee7fb6ebcb06cadf40ffd4c0 100644 (file)
@@ -1,26 +1,22 @@
+# SPDX-License-Identifier: GPL-2.0-only
 #
 # Copyright (C) 2016 Jiang Yutang <jiangyutang1978@gmail.com>
-#
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-#
+
 include $(TOPDIR)/rules.mk
 
 BOARD:=layerscape
 BOARDNAME:=NXP Layerscape
-DEVICE_TYPE:=developerboard
-KERNEL_PATCHVER:=4.4
-KERNELNAME:=Image dtbs
-FEATURES:=squashfs nand usb pcie gpio
-SUBTARGETS:=64b 32b
-MAINTAINER:=Yangbo Lu <yangbo.lu@nxp.com>
-
-include $(INCLUDE_DIR)/target.mk
+KERNEL_PATCHVER:=5.4
+FEATURES:=squashfs nand usb pcie gpio fpu ubifs ext4 rootfs-part boot-part
+SUBTARGETS:=armv8_64b armv7
 
 define Target/Description
-       Build firmware images for $(BOARDNAME) SoC devices.
+       Build firmware images for NXP Layerscape based boards.
 endef
 
-DEFAULT_PACKAGES += kmod-usb3 kmod-usb-dwc3 kmod-usb-storage
+include $(INCLUDE_DIR)/target.mk
+
+DEFAULT_PACKAGES += kmod-usb3 kmod-usb-dwc3 kmod-usb-storage \
+  mkf2fs e2fsprogs partx-utils
 
 $(eval $(call BuildTarget))